Ejecta Thread

Discussion and feedback on Construct 2

Post » Tue Aug 13, 2013 11:43 pm

Try disabling your plugins one by one @Rayek, and try to make a new game based only on C2 plugins so you can see if it works ;]
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Thu Aug 15, 2013 1:53 am

@NoFish, it actually does:

document.addEventListener('pageshow', function() {
    cr_setSuspended(false);
});
document.addEventListener('pagehide', function() {
    cr_setSuspended(true);
})
B
29
S
9
G
6
Posts: 525
Reputation: 8,294

Post » Sun Aug 18, 2013 10:09 am

Well, I succeeded in building a simple test project, and running it on the iPad. Much rejoicing!

Next, I am going to test if I can get my full game running. Fingers crossed!
Win7 64- i7 920@3.6Ghz, p6t Deluxe v1, 48gb, ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode
B
22
S
4
G
4
Posts: 98
Reputation: 3,955

Post » Fri Aug 23, 2013 6:50 am

I'm in dire need of some help.

Our game compiles in Xcode, and runs on the ipad, but after displaying the ejecta standard startup screen, it fades out to black, and then...

Nothing!

I tried running only our intro screen, and that runs. But trying to run the entire game, and no intro screen - the game will not display.

Any suggestions would be VERY appreciated.

Additional info:
- no physics used
- no external plugin used
- game works in Cocoonjs
Rayek2013-08-23 07:44:07
Win7 64- i7 920@3.6Ghz, p6t Deluxe v1, 48gb, ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode
B
22
S
4
G
4
Posts: 98
Reputation: 3,955

Post » Sat Aug 24, 2013 9:46 am

What's the xcode debug showing?
B
29
S
9
G
6
Posts: 525
Reputation: 8,294

Post » Sun Aug 25, 2013 8:10 am

It cannot find the jQuery object.
Win7 64- i7 920@3.6Ghz, p6t Deluxe v1, 48gb, ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode
B
22
S
4
G
4
Posts: 98
Reputation: 3,955

Post » Mon Aug 26, 2013 3:08 pm

Off topic: I guess that in case of iOS apps we can use Ejecta OR CocoonJS, yes? and the main disadvantage of CocoonJS is Ludei logo?
B
18
S
6
G
1
Posts: 783
Reputation: 4,167

Post » Wed Aug 28, 2013 5:09 am

@Rayek it's not supposed to use jQuery at all! There is something very wrong with your code, did you follow the steps?
B
29
S
9
G
6
Posts: 525
Reputation: 8,294

Post » Sat Aug 31, 2013 7:34 am

Yes, I did - I have no idea where that dependency is coming from, and I haven't spent too much time on it to fix it.

Next project will be compiled with Ejecta. I was able to get quite good performance in Cocoonjs and worked around the bugs.
Win7 64- i7 920@3.6Ghz, p6t Deluxe v1, 48gb, ATI 7970 3gb, EVGA 590 3GB, Revodrive X2 240gb, e-mu 1820. Screens: 2 x Samsung s27a850ds 2560x1440, HP 1920x1200 in portrait mode
B
22
S
4
G
4
Posts: 98
Reputation: 3,955

Post » Sun Sep 08, 2013 9:51 am

Sounds like you haven't copied the index.js file to the APP folder or you haven't run the (EjectaXporter_2d.bat) fnr to reaplace all the objects in the c2runtime.js file
B
7
S
2
G
1
Posts: 24
Reputation: 1,277

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 11 guests