Ejecta + X-code issues

Discussion and feedback on Construct 2

Post » Wed Dec 31, 2014 10:35 am

I've been trying to get this god damn app on the App store for a week now but I'm having no luck. I've tried another one of my simpler games and that ran fine in the simulator.

I'm using Ashley's Ejecta method (https://www.scirra.com/tutorials/992/ho ... ith-ejecta) and have tried numerous other tutorials.

Currently all I am trying to do is to get the game working in the x-code simulator. Is there an option or feature I need to disable in CS2 to get it working? What the hell is the god damn problem? I'm going crazy because of this...

1. The .capx file: (https://dl.dropboxusercontent.com/u/754 ... est11.capx)

2. Steps I do:
- Export project with Ejecta
- Upload to dropbox as .zip and download to mac.
- Download Ejecta from github
- Put project folder into Ejecta folder and rename as "App"
- Run the x-code file and build the project
- The simulator appears with Ejecta Splash Screen but it does not go past that
- Error in x-code pops up

3. The screenshot of the error (https://dl.dropboxusercontent.com/u/754 ... aerror.png)

Can anyone please help me? I have also tried CocoonJS but have architecture problems there so I'm currently stuck. Thanks for the assistance.
B
16
S
3
Posts: 115
Reputation: 2,428

Post » Fri Jan 02, 2015 3:45 pm

bump~
B
16
S
3
Posts: 115
Reputation: 2,428

Post » Fri Jan 02, 2015 8:38 pm

Alternatively:

Export project from C2 as 'Ejecta' to 'www' folder of a blank XDK project.
Export same project from C2 as 'Android' to same 'www' folder.
Build as iOS app.

This creates a valid iOS 'ipa' file that you can publish to the Apple store.

The Xcode route is way too problematic IMHO.

Good luck. :)
B
15
S
2
Posts: 229
Reputation: 1,353


Return to Construct 2 General

Who is online

Users browsing this forum: BackendFreak, htmlgames and 29 guests