Error loading project on Windows 8 tablet

Bugs will be moved here once resolved.

Post » Thu Mar 12, 2015 3:41 pm

Error loading project on Windows 8 tablet
I have a number of project on my desktop that I copied over to my Windows 8 tablet in order to work with them on the go. Upon opening any of the projects on my tablet I'm getting the following error saying there was an issue with the XML. See below picture:

Image

If I create new capx on the tablet and try to open it everything works as intended.

A few other things to note. Since the tablet has no storage space, Construct2 is installed on an SD card being used as an extra drive; the C2 projects are also stored on that secondary drive. I noticed if I open a capx by double clicking on it the license file is not detected and it starts in free mode. If instead, I navigate to the install directory and open the Construct2 exe directly everything functions as intended. Neither method or administrator mode lets me open the capx files from my desktop though.

Attach a Capx
I don't use capx files since I use version control software. I've uploaded a zip of the project

Description of Capx
The capx does not open.

Steps to Reproduce Bug
  • Click on capx to open/Open Construct2
  • Observe error.

Observed Result
The attached error is desplayed

Expected Result
The capx opens fine.

Affected Browsers
    N/A

Operating System and Service Pack
Windows 8.1 32bit (64bit processor)

This is the exact tablet I'm trying to open the capx on: http://www.microcenter.com/product/439773/TW700_Tablet_-_Black

Construct 2 Version ID
r195
You do not have the required permissions to view the files attached to this post.
B
38
S
9
G
7
Posts: 143
Reputation: 6,042

Post » Thu Mar 12, 2015 4:22 pm

This is a really old project built with r138.2 (july 2013) and is corrupt.

There are a couple of backup files, and removing the .backup1 extension (as stated in the manual) allows you to open the backup (see attached).

That may be the best you will get from this.
You do not have the required permissions to view the files attached to this post.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
129
S
29
G
74
Posts: 5,139
Reputation: 52,683

Post » Thu Mar 12, 2015 5:15 pm

Oh, I have this all backed up in source control so it was never about losing data. And yeah, this was an old project I abandoned so I didn't mind sharing it.

This issue still happens with my current project on r195, I just don't want to share it publicly. If @ashley has an email I can send it to I'd be happy to. :)
B
38
S
9
G
7
Posts: 143
Reputation: 6,042

Post » Thu Mar 12, 2015 5:21 pm

Ashley will say that unless you can give a simplified .capx with exact procedure for creating the issue then there will be nothing he can do.

This is just corruption and can happen for numerous, non C2 related reasons.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
129
S
29
G
74
Posts: 5,139
Reputation: 52,683

Post » Thu Mar 12, 2015 6:01 pm

Ok, I'll do that! This is important to me since I'll finally be able to work on my C2 projects on the go! Thanks for the pointers.
B
38
S
9
G
7
Posts: 143
Reputation: 6,042

Post » Mon Mar 16, 2015 1:31 pm

Closing as this is probably a corrupt project and not a C2 bug. We can help recover files if you send them to support email, but it's not always possible. You should have backups enabled and simply revert to an earlier backup.
Scirra Founder
B
381
S
222
G
84
Posts: 23,975
Reputation: 189,160

Post » Mon Mar 16, 2015 2:54 pm

No worries. I have everything in version control (git specifically) so it was never about losing a project, data or anything.

The issue was all my projects work on my PC but don't work on my Win8 tablet, I thought something else was wrong so I never considered project corruption... I suppose it could happen when transferring over the USB thumbstick?

Regardless I'll see if I can produce a minimal capx and more details next time.

Thanks!!
B
38
S
9
G
7
Posts: 143
Reputation: 6,042


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests