error on export - something with families

Bugs will be moved here once resolved.

Post » Wed Jan 18, 2012 7:55 pm

happens all the time on export to arcade

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot call GetAnimations() on family, check IsFamily() first

Condition: !object_class.IsFamily()
File: Projects\ObjectClass.cpp
Line: 151
Function: class cr::pod<class std::vector<class era::IAnimation *,class std::allocator<class era::IAnimation *> > > __thiscall ObjectTypeERACallback::GetAnimations(void) const
Build: release 75 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 2)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
???   ??? ????   ?????   
---------------------------
B
20
S
5
G
5
Posts: 37
Reputation: 4,072

Post » Wed Jan 18, 2012 8:12 pm

This bug already fixed in the next build.

@roidayan: please make sure the bug isn't already reported before posting it.

New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests