Error saving project -message

Bugs will be moved here once resolved.

Post » Sat Jan 14, 2017 7:38 am

Problem Description
Received an error message on saving the project. If this isn't proper forum to report this, I apologise.

Attach a Capx
For now, I won't because I think capx isn't causing this error message.

Description of Capx
I used C2 like normally and suddenly on saving, an error message pop-up. After clicking ok, I tried to save again and saving worked fine. This is a second time this error message pop-up.

Message: https://www.dropbox.com/s/24o8zcq4d770z ... 8.jpg?dl=0

Debug log: https://www.dropbox.com/s/5gw8wok6jeosg ... g.log?dl=0

Steps to Reproduce Bug
  • Save your project? I have no idea :/

Observed Result
Well, message pop-up, telling me to report it to Scirra.

Expected Result
Do like message told me to do. Report this message to Scirra.

Operating System and Service Pack
Windows 7 Professional SP1 64-bit running through vmware Fusion 5.0.5 (1945692) on Mac OS X 10.9.5

Construct 2 Version ID
r239 64-bit

-M-
B
16
S
2
Posts: 60
Reputation: 984

Post » Sat Jan 14, 2017 5:45 pm

Judging from the error message, this looks like C2 doesn't have the needed rights to save the project.
Try to save to the user folder (usually C:\Users\[Username]) or to the Desktop.

If that doesn't work, try to remove the ' in your file (=project) name.
Special characters some times screw up saving processes.

If that doesn't work either, you will need to upload your .capx.
(always do this, no matter what. It will help you get to a solution)

We will need to see whether it is your PC (or capx) and whether we can save it.
"We can't solve problems by using the same kind of thinking we used when we created them."
- Albert Einstein
B
27
S
11
G
8
Posts: 528
Reputation: 7,091

Post » Sat Jan 14, 2017 6:23 pm

I see. Thank you for your suggestions. I will report if this error message start to pop-up more often. Then I will also include capx-file.

Now that you mentioned it, I should avoid using special characters on project names from now on.

-M-
B
16
S
2
Posts: 60
Reputation: 984

Post » Thu Jan 19, 2017 6:08 pm

Sorry, not much we can do without a .capx and steps to reproduce - and even then it might be a permissions issue with the folder you're trying to save to, or a conflict with another piece of software trying to sync the files or something like that. (We've had trouble with Dropbox getting in the way of saves before.)
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests