Error when cloning (text) object

All closed bug reports are moved here.

Post » Wed Mar 29, 2017 2:12 pm

Steps to reproduce:
1. RMB on text object in the layout (so that you get a menu with options)
2. Choose the option "clone object type".
3. Do nothing and watch the error appear immediately.

Observed Result:
After giving the command to clone, an error appeared and C3 gives the option to restart.

Expected Result:
The object is cloned without error message and without needing to restart C3.

Example project file:
https://www.dropbox.com/sh/sacp3x92lt60 ... tRoba?dl=0


Error report information
Type: unhandled exception
File: https://editor.construct.net/r12/compon ... outView.js, line 1, col 29834
Message: Uncaught TypeError: this.ǃXX(...).then is not a function
Stack: TypeError: this.ǃXX(...).then is not a function at window.ǃhZ.ǃSAY (https://editor.construct.net/r12/compon ... js:1:29834) at X.size.V.ǃPN (https://editor.construct.net/r12/compon ... js:1:12978)
Construct 3 version: r12
URL: https://editor.construct.net/index.html
Date: Wed Mar 29 2017 15:54:43 GMT+0200 (West-Europa (zomertijd))
Uptime: 89.6 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.110
Browser engine: Blink
Browser architecture: 32-bit
Context: webapp
Operating system: Windows
Operating system version: 10
Operating system architecture: 32-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 2
User agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

WebGL information
Version string: WebGL 1.0 (OpenGL ES 2.0 Chromium)
Numeric version: 1
Supports NPOT textures: partial
Vendor: Google Inc.
Renderer: ANGLE (Mobile Intel(R) 4 Series Express Chipset Family (Microsoft Corporation - WDDM 1.1) Direct3D9Ex vs_3_0 ps_3_0)
Major performance caveat: no
Maximum texture size: 4096
Point size range: 1 to 256
Extensions: ANGLE_instanced_arrays, EXT_blend_minmax, EXT_frag_depth, EXT_shader_texture_lod, EXT_texture_filter_anisotropic, WEBKIT_EXT_texture_filter_anisotropic, OES_element_index_uint, OES_standard_derivatives, OES_texture_float, OES_texture_half_float, OES_texture_half_float_linear, OES_vertex_array_object, WEBGL_compressed_texture_s3tc, WEBKIT_WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_depth_texture, WEBKIT_WEBGL_depth_texture, WEBGL_lose_context, WEBKIT_WEBGL_lose_context
B
28
S
6
G
7
Posts: 681
Reputation: 5,682

Post » Wed Mar 29, 2017 2:33 pm

Fixed, should be in the next release :)
Scirra Employee
B
5
S
2
Posts: 129
Reputation: 889


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests