Error with effects, please help

For questions about using Classic.

Post » Sat Jan 24, 2009 5:59 pm

When i compile my game the following message apears: "<HLSL ERROR> Errors occurred compiling one of the FX files in your Effects directory. The application will run with effects disabled. You need to fix the FX script, or stop suing it, before effects can run correctly in this application."

The first level is using an effect(tint plus) and the system crashes when the game starts. Whe i try to add some effect in the game, construct also crashes.
Note: when i install older versions of construct the effects works properly.

Can anyone help me?
Really thanks!!
B
2
G
4
Posts: 19
Reputation: 1,088

Post » Sat Jan 24, 2009 6:13 pm

What version pixel shader does your hardware support? Does the error message give the details of the error in the .fx file? Which effects are you using and does it work if you remove all effects?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Jan 25, 2009 2:01 am

[quote="Ashley":1c8mnp8f]What version pixel shader does your hardware support? Does the error message give the details of the error in the .fx file? Which effects are you using and does it work if you remove all effects?[/quote:1c8mnp8f]

My hardware supports pixel shader version 3.0. Theres no other information in the message. I tried to remove all Effects but doesn't work.

The interesting thing is that i can't edit the game. When i select the layout that have the tint effect, construct crashes. But, if i select another layout that doesn't have effects, i can edit properly.
B
2
G
4
Posts: 19
Reputation: 1,088

Post » Sun Jan 25, 2009 2:45 am

Ok thanks everybody!! I fixed the problem! I made a Directx SDK actualization and now works fine!!
B
2
G
4
Posts: 19
Reputation: 1,088


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests