Event group crash

New releases and general discussions.

Post » Mon Nov 19, 2007 5:36 am

These two cap files are exactly the same, except that in 'problem_bad' a chunk of the code is in a group.

[url:2wui4id4]http://www.freewebs.com/jonnymataza/problem.zip[/url:2wui4id4]
B
2
S
1
G
5
Posts: 31
Reputation: 1,462

Post » Mon Nov 19, 2007 3:36 pm

Thanks for finding that one, was a tricky one :P Fixed for 0.86.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,590

Post » Thu Nov 22, 2007 12:50 am

[quote="mataza":d1dc69ie]These two cap files are exactly the same, except that in 'problem_bad' a chunk of the code is in a group.

[url:d1dc69ie]http://www.freewebs.com/jonnymataza/problem.zip[/url:d1dc69ie][/quote:d1dc69ie]

mataza, could you rehost that file somewhere else? I can't download it.

I'm having problems with grouped events not triggering properly, and I want to see if it's the same problem you were having before I go reporting a new bug.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Tue Nov 27, 2007 7:50 pm

I'm also having troubles with the groups. It seems that the order of grouped events get messed up.

Create a new game, and create a sprite with two animations. one red square and one green square. name them "red" and "green".

Now create these events:

Allways- sprite:set animation to "red"
Allways- sprite:set animation to "green"

and run the app. The sprite will be green.

Now put those events into a group without changing the order. The sprite will be red.

Edit: HAHAHAH! :P Forget it! I forgot to activate the group! LoL! But i have another app where i have this problem (no mistakes this time :wink: ) so the bug is still there.
B
8
S
2
G
5
Posts: 744
Reputation: 3,288


Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 2 guests