Every X Seconds bug

Bugs will be moved here once resolved.

Post » Tue Mar 06, 2012 3:17 am

Or maybe it might be chrome itself actually. I'm using the latest beta of chrome, and i notice that my stopwatch function appears to not follow the variable's delay value for "Every X Seconds" after a second or two, it will speed up for some reason. This does not happen in Firefox though.

Here is the example and see if you guys get the same result (excuse the hideous scale on the stopwatch, as i am just making sure you see the problem)

http://dl.dropbox.com/u/39646614/chromebug.capxPixelPalette2012-03-06 03:18:22
B
50
S
11
G
7
Posts: 274
Reputation: 8,146

Post » Tue Mar 06, 2012 1:50 pm

on Chrome 17.0.963.56 m looks fine, so probably it's some issues with beta version.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Tue Mar 06, 2012 2:53 pm

I've noticed this with the Chrome 18 beta, but it's a browser bug, the browser timer is going haywire. Hopefully they'll have this fixed by the stable release :P
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Mar 06, 2012 8:46 pm

Ah okay. Was pulling my hair out figuring out what was wrong. xD
B
50
S
11
G
7
Posts: 274
Reputation: 8,146

Post » Sun Apr 08, 2012 5:16 am

I've just come across this issue too.

Does anyone know if it is fixed in Chrome 19 dev?
B
26
S
5
G
5
Posts: 151
Reputation: 6,279

Post » Sun Apr 08, 2012 4:36 pm

@simwhi - sounds like the same as this open bug.

It's a browser bug and should be fixed in Chrome 19. I reported the issue to Google already. You can work around it by having an offscreen text object that you set to 'tickcount' every tick - this ensures the screen updates properly and should fix the problem.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Mon Apr 09, 2012 1:22 am

@Ashley - Thanks for the information.

This isn't a big issue for me at the moment, as I am developing Android based games. The timer works perfectly on Android phones.
B
26
S
5
G
5
Posts: 151
Reputation: 6,279


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests