EXE wrapper for HTML5 - alpha test

Discussion and feedback on Construct 2

Post » Fri Mar 02, 2012 1:39 pm

win7 64 pro
the only problem I've seen was the "program has stopped working" alert after closing the window
B
50
S
15
G
8
Posts: 8
Reputation: 6,423

Post » Fri Mar 02, 2012 1:50 pm

If you get the d3dx9_43.dll error, can you try installing this?

http://www.microsoft.com/download/en/details.aspx?id=35

It's similar to the DirectX update that Construct Classic needs. Turns out Chromium itself also requires it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Mar 02, 2012 2:04 pm

[quote]It's similar to the DirectX update that Construct Classic needs. Turns out Chromium itself also requires it. [/quote]

May have they been copying ?

Downoloaded it, played it, it worked as intended from start to end.
And it played good. That's pretty impressive.

There's room for a lot of improvement on the performances though.
It worked nicely on my PC, but an eye on the usage of the graphic card and the cpu showed a strong activity on my quad-proc (from 60 to 80 % on each core, i5-2500K - 3.30 Ghz) and about 11% of usage of the GC "only".

Nevertheless, the proof is there, efficient exe wrapping is closer than it sounded a few months ago.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Fri Mar 02, 2012 2:11 pm

Yes, it works flawlessly on my win7 64bit laptop. No errors at all.
B
50
S
11
G
8
Posts: 479
Reputation: 9,911

Post » Fri Mar 02, 2012 2:13 pm

TBH, if it runs well, the CPU/GC usage doesn't matter - it's there to be used to get the best performance. It does max out a core on my desktop here, but the performance seems smooth. Choppiness is more worrying.

I'll see if I can improve it - Awesomium seems to force an inefficient way of drawing.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Mar 02, 2012 2:14 pm

Hmm seems to take FOREVER to load here.. and when you open it sometimes, it starts instantly but missing sprites and invisible spaceship, but that might be the loading time.. used 5-10 min now still under 50% :S
CandyFace2012-03-02 14:16:31
B
20
S
5
G
4
Posts: 61
Reputation: 3,165

Post » Fri Mar 02, 2012 2:19 pm

@CandyFace, it has to load online at first, and there seems to be a bug that if you close it half way and launch it again, it doesn't finish loading so some things come up blank. However that's just because it's loading online, the real thing would load off disk so that would likely never happen.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Mar 02, 2012 2:22 pm

[QUOTE=Ashley]Please note: we may make this a licensed-only feature.[/QUOTE]
Don't. You can then enforce the "Made With Construct 2" splash screen like this to free users.
Tested in my work computer. dll issue, but game ran ok, sound and all. On close, there was an error message.
B
25
S
8
G
7
Posts: 184
Reputation: 6,040

Post » Fri Mar 02, 2012 2:37 pm

[QUOTE=Ashley] @CandyFace, it has to load online at first, and there seems to be a bug that if you close it half way and launch it again, it doesn't finish loading so some things come up blank. However that's just because it's loading online, the real thing would load off disk so that would likely never happen.[/QUOTE]

well.. after the load time, which was loong.. does the game run perfect, no glitches here. so this could look promising
B
20
S
5
G
4
Posts: 61
Reputation: 3,165

Post » Fri Mar 02, 2012 3:10 pm

[QUOTE=Ashley] If you get the d3dx9_43.dll error, can you try installing this?

http://www.microsoft.com/download/en/details.aspx?id=35

It's similar to the DirectX update that Construct Classic needs. Turns out Chromium itself also requires it.[/QUOTE]

After installing that, there are no more errors when opening the game, although for some reason now the game runs very slow, but it might be unrelated to this.
B
63
S
23
G
17
Posts: 254
Reputation: 14,342

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests