Export - HTML5 issue

All closed bug reports are moved here.

Post » Tue Mar 28, 2017 5:25 pm

When exporting my project to HTML5, I am having a black screen (after seeing a Construct2 splash screen). The preview in Construct 3 works fine.

Project file: https://www.dropbox.com/s/okb2wqb4tujh5t1/Test%20Beta%2001.c3p?dl=0

The test project was created from scratch, using the font import function.

Live preview (Works ok):
https://www.dropbox.com/s/9sw202dsgbu020l/preview.PNG?dl=0

HTML5 splash screen:
https://www.dropbox.com/s/e65193o8vjb71u8/export01.PNG?dl=0

HTML5 black screen:
https://www.dropbox.com/s/i5sfq1ikeymapn4/export02.PNG?dl=0

Export .ZIP (with minify option):
https://www.dropbox.com/s/vdokey9ogzhk4qb/Test%20Beta%2001.zip?dl=0

Platform information
Browser: Chrome
Browser version: 57.0.2987.110
Browser engine: Blink
Browser architecture: 64-bit
Context: browser
Operating system: Windows
Operating system version: 7
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 4
User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36
B
21
S
6
G
5
Posts: 51
Reputation: 4,999

Post » Tue Mar 28, 2017 7:27 pm

When executing a project, try to check for errors in browser.
If the console shows errors do post them they will be clues as to what may be going on.

Also your screenshot indicates a localhost server. Is the issue the same if you host online ?
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
291
S
114
G
95
Posts: 7,290
Reputation: 70,138

Post » Wed Mar 29, 2017 6:03 pm

FIXED!

I needed to add the following MIME type in IIS: .woff = application/x-font-woff

Thank you!
B
21
S
6
G
5
Posts: 51
Reputation: 4,999


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests