Export to Intel XDK- Android app not working

Bugs will be moved here once resolved.

Post » Wed Aug 28, 2013 9:53 pm

The app runs fine on the Android using the app-lab simulator but not when built as an app (.apk)It's basically the template.

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/5348879/XDKtestforAndroid2.capx

Steps to reproduce:
1. Create New Project from XDK template. Added 1 text object and Changed orientation to landscape
2. Export to Mobile - > Intex XDK
3. "Use Standard PNG compression" checked
4. "Minify script (recommended)" checked
5. "Rendering" set to "Use phone browser" (also tried with "Use app Interfaces"
6. Export to Intel XDK project following the XDK tutorial
7. Ran using "Test Local" simulator on Android tablet (runs fine)

8. Build for android using Intel XDK build 1028
9. Copied .apk to tablet, installed the app.
10.Ran android app. Doesn't work.

Observed result:
Screen with grey bars


Expected result:
I expected it to open and run on the tablet.

Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Operating system & service pack:
Windows 7 64bit, Service pack 1
Construct 2 version:
Version 139 64bit
B
24
S
4
G
3
Posts: 43
Reputation: 2,795

Post » Wed Sep 04, 2013 10:52 am

I have the same problem too. Any solutions to this?
B
23
S
9
G
3
Posts: 114
Reputation: 3,794

Post » Wed Sep 18, 2013 1:12 am

the "test" tab says to install "app lab" for ios or android. i can't find any such app in either store.

is this another one of those projects with Intel throwing around some money, only to not work and be canned quickly? (i.e. intel doesn't do software right)
B
2
Posts: 1
Reputation: 152

Post » Wed Sep 18, 2013 3:45 pm

@eturk Try this link for the ios app. It does exist and I have it installed. It can be hard to find because the itunes app store search engine is incredibly bad at finding things.

The intel XDK seems really well thought out and very comprehensive, now if I could only get it to work with C2.
B
24
S
4
G
3
Posts: 43
Reputation: 2,795

Post » Thu Sep 26, 2013 10:11 pm

Same prob. No solutions?
B
5
S
1
Posts: 12
Reputation: 477

Post » Tue Oct 15, 2013 3:58 pm

The 'observed result' screenshot - the stripes look the same as the background on some of the demos - when you set up the project in the xdk, what option did you use for the development path? I wonder if at this stage it is using one of the demo templates?

Did you export into the right folder e.g. user/xdk/user.appname/4.0.0

I've only just started using it myself - but it might point you in the right direction!sainsy2013-10-15 16:00:41
B
8
S
2
G
1
Posts: 45
Reputation: 1,007

Post » Wed Oct 16, 2013 5:53 am

Thanks for taking a stab at it but yes, the export folder is correct. All works fine in the emulator, just not after installed via the compiled apk. I don't think it would run in the emulator or on the tablet at all with an incorrect path.

I just updated C2 recently so I might try Intel XDK again soon, but since I got no usable solution I gave up and have been using coccoonjs successfully for Android apps.
B
24
S
4
G
3
Posts: 43
Reputation: 2,795

Post » Wed Oct 16, 2013 12:12 pm

The OP .capx link is now 404. If you put it back up I can investigate your specific project. Last I tried though Space Blaster exported and ran just fine in the XDK.
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,661


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests