Export to NW.js problems - Breaks everything that works

Discussion and feedback on Construct 2

Post » Tue May 05, 2015 1:45 pm

To follow up what I was talking about before. I finally figured out why our game was breaking on NW.js export.
It seems that upon export, all animated sprites with overlay effect break. However, all non-animated sprites with overlay effect still work perfectly.
I tried creating a new project confirming my suspicions and I was able to re-create the bug 100%.

To clarify, animated sprites with overlay effect seem to work in preview but as soon as the project is exported to NW.js it all goes south.
B
42
S
23
G
18
Posts: 154
Reputation: 12,475

Post » Tue May 05, 2015 2:57 pm

purplemonkey wrote:To follow up what I was talking about before. I finally figured out why our game was breaking on NW.js export.
It seems that upon export, all animated sprites with overlay effect break. However, all non-animated sprites with overlay effect still work perfectly.
I tried creating a new project confirming my suspicions and I was able to re-create the bug 100%.

To clarify, animated sprites with overlay effect seem to work in preview but as soon as the project is exported to NW.js it all goes south.


When you say they work in preview are you previewing using NW.js?
FREEDOM: Diegesis - Out Now for Windows! http://freedom.quicksandgames.com
B
22
S
5
G
1
Posts: 83
Reputation: 1,818

Post » Tue May 05, 2015 3:02 pm

Quicksand wrote:When you say they work in preview are you previewing using NW.js?

Yup!
B
42
S
23
G
18
Posts: 154
Reputation: 12,475

Post » Tue May 05, 2015 3:15 pm

@purplemonkey - did you do your bug report yet?
Image
B
20
S
4
Posts: 382
Reputation: 2,974

Post » Tue May 05, 2015 3:23 pm

PSI wrote:@purplemonkey - did you do your bug report yet?

Not yet!
B
42
S
23
G
18
Posts: 154
Reputation: 12,475

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests