Exporting for Mobile Distribution

Get help using Construct 2

Post » Mon Apr 06, 2015 3:38 pm

After going through what feels like dozens of pages of instructions for exporting to mobile, and getting increasingly frustrated, I am hoping to save others the time I have spent by consolidating the latest and greatest.

The only one that I have been able to get built successfully is Android. iOS works in Intel XDK Emulate and Test until I add in the certificates, keys, etc then it wont build. Windows exports from C2 fine but then gets corrupted when pulling into Visual Studio.

My game is pretty basic and the only plugin is for adMob. The goal is to produce an install package for distribution on the platform noted and adMob ads running in specific Layouts within the game, ie end of level and score display.

HTML5 for hosting on my site exports are default from C2 and monetization will be via adSense. I am hoping to find a Wordpress arcade/games add-on to do this. I dont believe adMob works outside an app but open to suggestions there as well.

I am running C2 r200 on Windows.

Here are the platforms and, from what I can tell, the latest and/or most successful build processes for mobile:

The iOS Web App method is interesting but I think it would be difficult to promote and monetize. You would have to use something like adSense next to, or above/below, the game and it would be visible at all times, detracting from the game. Not the experience I am wanting to provide.

I am hoping others can confirm their success with the above methods. Otherwise I am sure others would also appreciate information on more tried and true processes people have used to achieve a viable export to each platform.
B
7
S
3
Posts: 30
Reputation: 687

Post » Thu Apr 30, 2015 2:46 pm

Quit tip for those that might be having trouble with Windows Phone.

I successfully exported to Windows Phone 8.1, loaded into Visual Studio 2013, built the .xap and deployed to my device.

The game would load to 98% but then hang. I tried in browser and found that the same thing happened when loaded the HTML5 exported version.

I found that if I disabled WebGL the game would load. I went through the process for exporting the Visual Studio file and building the xap and it worked.

Long story short, disable WebGL before exporting the project.
• Select Project Name
• Located "Enable WebGL" in the Properties/About

Not all the features of my game are working, such as posting scores into the db stored on my server, but at least it loads and most of it works.

Hopefully others find this helpful.
B
7
S
3
Posts: 30
Reputation: 687


Return to How do I....?

Who is online

Users browsing this forum: R0J0hound and 7 guests