Facebook not loading correctly | Cordova | Android

Report Construct 2 bugs here.

Post » Sat Oct 29, 2016 2:08 am

Problem Description
This happens with phonegap builds aswell as Intel XDK builds. It seems like the channel url tries to open with "file://" and thus cannot find the all.js The facebook API then doesn´t load at all. This only happens when the app is installed on a mobile device or testing it via Phonegap/Intel XDK. Works fine in browser or with constructs test feature. The application was signed.

Image

Attach a Capx
I don´t think one is really needed, right? It just contains the Facebook plugin. I can provide one if you really want. Or provide the .apk.

Description of Capx
-

Steps to Reproduce Bug
  • Trigger some event on "Facebook is ready" e.g. Browser alert.
  • Export with cordova
  • Build either with Phonegap or Intel XDK
  • Install build on device, check if "Facebook is ready" gets triggered

Observed Result
Facebook API fails to load.

Expected Result
Load this thing goddamnit, I fixed about 200 other things in search of finding a solution for this one.

Affected Browsers
  • Only when installed on the device / testing via Phonegap or Intel XDK

Operating System and Service Pack
Android 6.0.1 (appears to also have failed on an earlier version 5.?.? on a friends device, couldn´t debug there though.)

Construct 2 Version ID
C2 R239

Please witness me almighty @Ashley
B
16
S
3
Posts: 69
Reputation: 1,048

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest