FACEBOOK Platform upgrade to version2.0

Discussion and feedback on Construct 2

Post » Thu May 01, 2014 9:33 am

Hi Guys,

I'm a newbie. Wasted half a day trying to resolve something because I was not up to date with changes in Facebook.
Please ignore this if you are aware of this upgrade on Facebook. My intention is to post this for other guys like me, who always look for support from these helpful forum posts.

I just ran into a problem (sourcing invitable friends - friends who haven't signed up for my app) while working with a facebook app, and found out that Facebook platform has been upgraded, and that apps need to make changes to interact with FB.

Please check the link:
https://developers.facebook.com/docs/apps/upgrading

Important points:
For apps created before April 30th 2014, making API calls without specifying a version number is equivalent to calling v1.0 of the API.
For apps created on or after April 30th 2014, making API calls without specifying a version number is equivalent to calling v2.0 of the API. These apps won't be able to call v1.0 of the API.
Version 1.0, which is what we call the API as it existed the day before v2.0 was launched. We'll support v1.0 for one year and it will expire on April 30th, 2015.
Version 2.0, which is what this upgrade guide covers. Version 2.0 is supported for at least two years. At the earliest, it will expire on April 30th, 2016.

You can choose which version of the API you want to use by:
Initializing the JavaScript SDK with the version you want to use and then making calls through FB.api(), which will automatically route API calls to the versioned endpoint you choose.
Integrating the Facebook SDKs for iOS or Android, which are set up to call the latest version of the API that was available on the day the SDK was released.
For people making manual calls to our API without an SDK, the version is picked by putting the version in the path when you make an API call (such as graph.facebook.com/v2.0/me).

runtime.js for Facebook plugin may need to be updated
js.src = "//connect.facebook.com/en_US/all.js";
You should update it to:
js.src = "//connect.facebook.com/en_US/sdk.js";

Add "version : 'v2.0'," to FB.init


Cheers,
Capper
B
7
S
1
Posts: 15
Reputation: 465

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests