Failed to open project... How do I fix this?

Get help using Construct 2

Post » Fri Dec 05, 2014 8:45 am

When I try to open my project a window opens which says the following:

"Cannot find object texture file 'SpriteFont.png' in the project texture folder. Check the file has not been renamed or removed.
Under element: c2project \ object-folder \ object-type
Line 4519, column 9"

Not sure quite what it means but I haven't renamed any SpriteFonts and it's preventing me from opening my project.

Help me guys :(
B
4
S
1
Posts: 9
Reputation: 918

Post » Fri Dec 05, 2014 9:32 am

Hey @Cody, do you save your file as a C2project (in a folder) or is it a capx? If it's a capx, you can decompress it with your regular compression software (7-zip, winrar...) and add an image named "SpriteFont.png" in the object-type folder. This should solve your issue.

Good luck!
B
79
S
22
G
4
Posts: 311
Reputation: 12,774

Post » Fri Dec 12, 2014 11:29 am

Thanks Valerian,

I'm still having problems though. I decompressed the project and it turns out there's no textures or animations folder? I tried creating a texture folder and adding a "SpriteFont.png" image but upon opening my project the same error message occurred, this time replacing "SpriteFont.png" for "Option1.png". I added another image to the folder named Option1 but the error message came up again saying I needed "Option2.png" and then later "9patch.png".... I'm Hoping I don't need to replace all of the textures in this way and also that I don't need to replace all of my animations too, because I had a lot -.-

Is there anyway I can recover the two missing folders? :oops:
B
4
S
1
Posts: 9
Reputation: 918

Post » Fri Dec 12, 2014 2:57 pm

nope. you can't.
btw. check if you have .backup file ? you can restore your project to the last working state.

also create then a empty folder on your desktop and save as project in it. check if everything is there -> therefore you get back your folders and stuff.
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
43
S
14
G
12
Posts: 626
Reputation: 9,450

Post » Sun Dec 14, 2014 12:11 am

Tried restoring with the backup, same error... Oh well thanks guys
B
4
S
1
Posts: 9
Reputation: 918

Post » Sun Dec 14, 2014 12:17 am

@Cody it looks like you lost some images in you project. Have you move your project directory recently? or deleted anything?
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Sun Dec 14, 2014 12:28 am

No I haven't. All I did before this thing happened was add a few animations to one of my sprites and then save and exit.
B
4
S
1
Posts: 9
Reputation: 918


Return to How do I....?

Who is online

Users browsing this forum: Artcadev, brunopalermo, lahbach and 14 guests