Family bug?

Bugs will be moved here once resolved.

Post » Wed Feb 27, 2013 7:11 pm

Link to .capx file (required!):
https://dl.dropbox.com/u/58042250/Construct/Cap.capx

Steps to reproduce:
1. Create two sprites ("buttons") looking exactly the same with two
similar animation frames each
2. add the sprites to a family
3. Create an event that makes one sprite in the family change to
animationframe 1 (instead of 0) when the mouse is over the sprite, and one for the exact opposite (when the mouse is not over the sprite, the animation goes back to frame 0)

Observed result:
Both sprites flicker to animationframe 1 upon the mouse hoovering over one of the sprites (only the first time it occurs in the session)

Expected result:
Only the sprite that the mouse is over should change animationframe

Browsers affected:
Chrome: yes
Firefox: yes/no
Internet Explorer: yes/no

Operating system & service pack:
Windows 8 64 bit

Construct 2 version:
    Construct 2 r119
B
6
G
2
Posts: 39
Reputation: 1,280

Post » Mon Mar 04, 2013 5:46 pm

Closing as not a bug. The animation speed is 5, so the other object proceeds with its animation once "mouse not over button" is not true (since the mouse is not over the other object). Works if you set the animation speed to 0.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

Post » Thu Mar 07, 2013 10:28 pm

Sorry, I guess it was just a brainfart from my ol' brain haha :)
B
6
G
2
Posts: 39
Reputation: 1,280


Return to Closed bugs

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests