Family Picking Problems 99.7 vs 99.8

Post your own tutorials, guides and demos.

Post » Thu Jan 28, 2010 9:34 pm

I can't put it back - it's fixing a bug. I understand your frustration, but it's not an unintended feature, it's a bug which could result in instability of the engine, hence we corrected it to work like it always has everywhere else in Construct. If I left it in, you might find your project randomly crashing because you're depending on an unreliable part of the engine. It's a fix, your project is now more stable, the side effect is you have to change the events that use an old glitch in the engine.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Jan 28, 2010 10:50 pm

[quote="Ashley":1y6op5o7]I can't put it back - it's fixing a bug. I understand your frustration, but it's not an unintended feature, it's a bug which could result in instability of the engine, hence we corrected it to work like it always has everywhere else in Construct. If I left it in, you might find your project randomly crashing because you're depending on an unreliable part of the engine. It's a fix, your project is now more stable, the side effect is you have to change the events that use an old glitch in the engine.[/quote:1y6op5o7]

Of course you're absolutely right Ashley. I guess we'll still have to wait for Construct 2 for created objects to actually exist at the same event line. Which I guess this issue is related to.

So it's just a matter of changing my habits really. Which most people hate to do, haha. :mrgreen:
B
21
S
6
G
10
Posts: 1,024
Reputation: 7,445

Post » Fri Jan 29, 2010 3:00 pm

[quote:2hnx4dvy]it seems to only affect events with Create Object actions[/quote:2hnx4dvy]

I have not used any Create Object action. I will try to update the game and post any news that I can find.
B
30
S
15
G
10
Posts: 285
Reputation: 7,144

Post » Sun Jan 31, 2010 12:53 am

Thanks for the help.

I've looking it over and still can't make sense of it. BUT! I've narrowed down one line of code that doesn't work in 99.72+ but works in 99.7.

There is a corner button and three circle button. The circle buttons are supposed to be layed around the corner button as they are when you compile the .cap in 99.7. But when you compile it in 99.8 the circle buttons are clumped together.

So, am I picking families wrong? Or is this a bug?
Follow me on Twitter @evgLabs
B
33
S
14
G
4
Posts: 251
Reputation: 4,049

Post » Sun Jan 31, 2010 11:38 am

Changing the first "equal" to "less or equal" seems to work. Maybe the bug is related to value comparisons.
B
30
S
15
G
10
Posts: 285
Reputation: 7,144

Post » Sun Jan 31, 2010 2:36 pm

Just a heads up - I talked about this family picking thing in this thread. It was pretty confusing since two family-related things subtly changed in the past couple of builds, but this is the main one I think, causing family expressions in the form Family.Expression to have slightly different results. It should be fixed in the next build, but it reopens an older bug where Family.Count returns 0 or the wrong count.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Jan 31, 2010 2:47 pm

Ok. Thanks for the Help!
Follow me on Twitter @evgLabs
B
33
S
14
G
4
Posts: 251
Reputation: 4,049

Previous

Return to Your tutorials & example files

Who is online

Users browsing this forum: No registered users and 0 guests