FB 'Prompt to Share App' not showing graphic.

Bugs will be moved here once resolved.

Post » Mon Nov 23, 2015 12:04 pm

Problem Description
I am using "Prompt to share app" after condition of Facebook API ready and user logged in.
The prompt works, everything works EXCEPT it doesn't show the image I supply the URL for,
I've tried it as PNG and JPG, I've tried it thru https and http.
No matter what I can't get the darn icon to show.

Are their specs for its size? (It's not huge, just normal icon.
Further, C2 says that in absence of link, it will use loading-logo.png.
I tried no link and no logo showed. I'm at a loss. Please help!

Thank you!

Here's the game, live on Facebook: https://apps.facebook.com/tapcatgame

Attach a Capx
Image of code attached
Image

Here is the CAPX it activates when it is on a server and can post to FB, doesn't activate locally.
http://www.larrynocella.com/images/post%20to%20FB%20issue.capx

Description of Capx
should share info and icon, only shares info. everything works except it doesn't show the icon

Steps to Reproduce Bug
Play it once, and after it will ask to share your score on your Facebook feed, if you are logged in to Facebook
In the share box, no icon will appear

Observed Result
All works but no icon appears
https://youtu.be/GBPEjj8bDsU

Expected Result
Icon to appear in FB share window

Affected Browsers
Same result on Chrome and Edge

Operating System and Service Pack
Win 10

Construct 2 Version ID
C2 beta rel r217
B
27
S
5
G
2
Posts: 38
Reputation: 2,414

Post » Sun Dec 06, 2015 3:18 pm

Please close this and accept my apologies. This is not a bug. I discovered solution by accident. FB requires the icon be a certain size. When I tried it accidentally with a 128 x 128 icon (instead of the smaller size I was using) it worked great. Thanks as always, Scirra!
B
27
S
5
G
2
Posts: 38
Reputation: 2,414


Return to Closed bugs

Who is online

Users browsing this forum: dimielannes, SecondDimension and 2 guests