FIREFOX 37 / Multiplayer no longer works

Bugs will be moved here once resolved.

Post » Fri Apr 17, 2015 1:41 pm

Problem Description
____ A concise description of your problem here ____

I've been using the Multiplayer function for a long time with no problems in FIREFOX.

But now... the new FIREFOX 37 seems to break Multiplayer.

You can be a HOST, but not a CLIENT.

A client using FIREFOX 37 seems unable to connect to the HOST.

(This is not a signaling server issue, but a client to host issue).

If I run the exact same code on FIREFOX 35, it works fine.

If I run the exact same code using CHROME it works fine.

I've observed the same effect on PC and MAC versions of FIREFOX 37. (And multiple version of windows).

Attach a Capx
____ Upload a Capx to this post ____

I tested this using your MULTIPLAYER DEMO CODE.

Description of Capx
____ Concise description of what this CapX does ____

Steps to Reproduce Bug
  • Step 1
  • Step 2
  • Step 3 etc.

Observed Result
____ What happens? ____

The CLIENT can't see the HOST.

Expected Result
____ What do you expect to happen? ____

The CLIENT should connect to the HOST.

Affected Browsers
  • Chrome: NO
  • FireFox: only version 37
  • Internet Explorer: can't test this because no WebRTC support.

Operating System and Service Pack
____ Your operating system and service pack ____

Tested lots of machines, both PC and MAC

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____

Your latest stable release.
B
11
S
2
Posts: 19
Reputation: 889

Post » Fri Apr 17, 2015 2:02 pm

+1
You think you can do these things, but you can't, Nemo!
Just keep reading.
Just keep learning.
B
65
S
16
G
9
Posts: 1,429
Reputation: 12,708

Post » Tue Apr 21, 2015 1:30 pm

Thanks for the heads up, looks like the spec changed and we needed to tweak it for Firefox support. Should be fixed in the next beta.
Scirra Founder
B
395
S
233
G
88
Posts: 24,376
Reputation: 193,852


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests