Firefox Sound Issues?

Discussion and feedback on Construct 2

Post » Thu Sep 20, 2012 8:01 pm

Is it just me or is sound playing incorrectly again in Firefox 15.0.1? Everything is crackly\stuttering, especially music.

Chrome is working well as usual.

Every game is ruined for me in the Arcade because of this. How annoying!

BTW, I realise that this is probably nothing to do with C2, just wanted to see if others are having the same problem.

Could put off potential buyers if they are getting the same problem.


Zeus2012-09-23 12:37:35
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Post » Sun Sep 23, 2012 3:05 am

I haven't had this problem, so I'm not sure what it would be.
B
7
Posts: 19
Reputation: 778

Post » Wed Oct 10, 2012 8:05 am

Firefox just updated to version 16 and the problem still exists for me. IE and Chrome work fine though.

I`m not sure if this is worth looking into but I just wanted to mention it. I know that you have mentioned in the past that it is not a problem with C2 but if I was a first time buyer and did`nt know better it would stop me from making a purchase which would be a shame.

I will see if I can find the cause of this.Zeus2012-10-10 08:05:44
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Post » Wed Oct 10, 2012 9:54 am

I haven't heard of anyone else having this issue. Have you tried Firefox on different computers to see if maybe it's just an issue with one?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Wed Oct 10, 2012 4:18 pm

It's been working fine for me as well. Do you have a another PC or friend that can run what you are on FireFox and see the same issues exist?

EDIT: Sorry, I basically repeated what Ashley said.

Also, I noticed on my laptop if I have a music player running at the same time and then stand by my laptop and restart,it causes funny sound noises like you described.

Also, see if there is an update on your sound driver

aindovin2012-10-10 16:19:21
B
16
S
6
G
5
Posts: 90
Reputation: 4,324

Post » Wed Oct 10, 2012 5:26 pm

Hi guys, OK, I have the latest drivers for all of my hardware so that is not the problem. I have also seen the problem on another Computer running Firefox, the only similarity is that we are both using a 64-Bit OS but Firefox version is 32-Bit I believe. Different soundcards though so it cannot be that. I`m on Vista the other Windows 7.

I can send a small video or sound file to you Ashley if you would would like to hear what is happening. Just let me know.

I do not want you to waste your valuable time on this however, I just wanted to point it out. If others are not having the same problem then please do not worry I`m sure that you have plenty to keep you busy.
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Post » Thu Oct 11, 2012 4:48 pm

Hi Ashley, while trying to find a possible cause of this problem for you I was playing Skygear-01 Destroyer in the Arcade and I noticed that the music only stutters until I press the fire button.

I`m not sure whether it is because another sound effect is playing or it`s because I`m pressing a button down but for a few seconds the music plays fine and then it starts to stutter again until I repeat the process. As mentioned above I can provide a small video for you if needed.

I am also controlling the ships movement with the keys but the music only plays concretely when I press fire so it must be something to do with another sound playing? Very weird indeed.

Any ideas? Zeus2012-10-11 17:08:49
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Post » Thu Oct 11, 2012 6:44 pm

have you tried adding the Firebug addon for Firefox and see if anything comes up? Or maybe something similar? I might be plowing through an error or something. Just a grasp at straws but may not hurt.
B
16
S
6
G
5
Posts: 90
Reputation: 4,324

Post » Thu Oct 11, 2012 6:59 pm

@Zeus

probably same problem as this :
http://forums.mozillazine.org/viewtopic.php?f=38&t=2542145

try to add: "media.use_cubeb" ---> "false" preference,
looks like it fix the problem for some of the poster there.

from this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=788005#c6
B
34
S
13
G
8
Posts: 134
Reputation: 8,118

Post » Thu Oct 11, 2012 7:01 pm

Good find Potato. I bet that is it.
B
16
S
6
G
5
Posts: 90
Reputation: 4,324

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests