Firefox WebGL faster than Chrome WebGL?

Get help using Construct 2

Post » Sat Feb 11, 2012 12:06 am

I've always done my testing and previewing in Chrome and it's worked fine up until a few minutes ago, now for some inexplicable reason (despite multiple reboots), chrome webgl is down to 4/5 fps for even the simplest of html5 tests.

If I switch webgl off in Construct, then it runs significantly better. I then decided to do a preview in Firefox with webgl, and it works fine!!! I also went to some random WebGL programs such as this one
https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/demos/webkit/Earth.html

and I get 20 fps in firefox and 4 fps in Chrome, so it's not just Construct. I've got Chrome 18.0.1025.11 beta-m and Firefox 9.0.1.

Does anyone have any theories about how Chrome WebGL could suddenly get corrupted? Can someone chime in about what version of Chrome they are using? I haven't changed anything, or installed any extensions or plugins, so I have no idea what is going on.

Thanks for any advice,
-- cacotigon
B
30
S
6
G
8
Posts: 232
Reputation: 6,119

Post » Sat Feb 11, 2012 1:00 am

FF latest version is 10.0.

I get 59 FPS in FF 10.0, 61 FPS in chrome (17, I only update on stable releases) on the Earth test.

I don't believe chrome's webGL should "take such a plunge".
Maybe a bug you should report to chromium.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Sat Feb 11, 2012 1:56 am

Did your computer support WebGL before hand?

I'm on Chrome 18 beta too and it has a feature where it will use a software renderer for WebGL if it's not supported, with the intention of making 3D stuff work. They've licensed one of the fastest software renderers in the world for it apparently, but it's still nothing compared to real hardware. The problem is we've benchmarked WebGL and found it to be 2-3x faster than canvas 2D in the past, because WebGL was always hardware accelerated. Now they're adding a software renderer for WebGL it's worrying because it might "usefully" switch to the software renderer when WebGL is not supported, which may be slower than the canvas 2D. Hopefully it won't affect many people because it won't take over if hardware-accelerated WebGL is available, but still, WebGL doesn't work everywhere... I'm going to try contact them to figure out if this will be a problem.

Meanwhile if you go to chrome://gpu, does it list everything as hardware accelerated at the top?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sat Feb 11, 2012 2:43 am

It's weird, I mean, I can't be sure if it did support WebGL before, since I only started working with Construct about a month ago, but all of my Construct projects have always been set to WebGL, and the framerate has always been decent.

I checked the about:gpu page:
All of the options were set to *not* hardware accelerated, so I went to the about:flags and enabled "Override software rendering list", and now it reports:
Canvas: Software only. Hardware acceleration disabled.
HTML Rendering: Hardware accelerated
3D CSS: Hardware accelerated
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated

Canvas is set to software, but WebGL is hardware accelerated, so does that mean webgl construct apps are hardware accelerated?

It also seems to run smoother. I just wonder what changed to make this happen in the first place.
B
30
S
6
G
8
Posts: 232
Reputation: 6,119

Post » Sat Feb 11, 2012 7:13 am

I have noticed this before. But today it got into my way. Apprently Chrome seem to occupy a lot of memory but Firefox is using very little.

Here is an example, I am trying to create a fog of war effect using a canvas and the compositing methods available.

There is a great difference in performance between Chrome and Firefox. With Chrome the memory usage increase sharply when I move around while there is no increase in memory usage in Firefox.

When I disalble webgl, the performace was as smooth as in Firefox. Is it that Firefox is not using webgl? From chrome://gpu I got the same result as cacotigon. I tried enabling hardware accelaration for 2D canvas but didnot help.

I am actually creating a plugin for fog of war, I see similar performance issues there.

Is this a propblem with chrome or webGL?Danijerry2012-02-11 07:19:16
B
28
S
9
G
6
Posts: 30
Reputation: 6,609

Post » Sat Feb 11, 2012 9:13 pm

Well, I figured out that webgl is not enabled in Firefox in my case. Also my graphics drive was not updated. So I updated my graphics driver and webgl was enabled in Firefox. Now I see equivalent use of memory usage by both Chrome 17 and Firefox 10.

I see that manipulating the canvas object very often something like every tick costs a lot a memory when using webgl. The memory usage accumulates before it is released leading to a point when the game is irresponsive.

Is there any optimization for this!
B
28
S
9
G
6
Posts: 30
Reputation: 6,609


Return to How do I....?

Who is online

Users browsing this forum: Televangelist and 17 guests