Firing a bullet makes my Sprite jump backwards

Get help using Construct 2

Post » Tue Sep 16, 2014 1:44 am

I have an issue I cant seem to stop from happening. In my game a ship is firing a bullet. For some reason when it fires the bullet the ship sprite jumps back.

This didn't always happen using the same logic for the mouse click so I am at a loss. Any help would be appreciated.
You do not have the required permissions to view the files attached to this post.
B
2
Posts: 8
Reputation: 166

Post » Tue Sep 16, 2014 5:22 am

Hard to tell without a capx, what behaviors do you have on the ship and redball?
perhaps the ball is pushing the ship back with physics or something.
try spawning the ball elsewhere see if it helps, if it does, just add another image point away from the edge of the ship, far enough to fit the ball, and spawn it there.
Image
B
80
S
30
G
12
Posts: 517
Reputation: 12,713

Post » Tue Sep 16, 2014 7:27 am

maybe because it has solid behavior.
"If you want to move a mountain tomorrow, you should start by lifting stones today."
B
64
S
14
G
2
Posts: 292
Reputation: 6,678

Post » Tue Sep 16, 2014 11:28 am

puntodamar wrote:maybe because it has solid behavior.



You were right! I was under the false assumption that an object needed to have the solid property to collide but I guess not. Thank you both for your ideas!

:D
B
2
Posts: 8
Reputation: 166

Post » Tue Sep 16, 2014 1:34 pm

you're welcome. good luck on your game :)
"If you want to move a mountain tomorrow, you should start by lifting stones today."
B
64
S
14
G
2
Posts: 292
Reputation: 6,678


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 6 guests