fixed / bug with collision family r95

Bugs will be moved here once resolved.

Post » Mon Jun 18, 2012 1:21 am



im having this strange bug whenever an object hits a member of a family

thing is, i cant recreate it and im using a couple of external plugins, but dont know what to do now

vtrix2012-06-18 01:30:06
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Mon Jun 18, 2012 1:29 am

scrap that, i was using objects that were saved in json, but the new variables were not in them, therefore the error
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Mon Jun 18, 2012 6:37 pm

It should not normally be possible for this error to occur. Was it a broken third party plugin? Can you explain a bit more what was going wrong? I might still be able to make a change to prevent anyone else having this problem.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Mon Jun 18, 2012 6:52 pm

im using spritebank plugin to save my sprite pos, angle, vars...

i exported the json from all this to a file that gets loaded when start of layout

later on i created a new variable for this family and made a collision event that changed that var, then i got this error (on collision)

because spritebank loaded the json from sprites that didnt have this variable i got this error,

the solution was delete the old json string and save with the new objects

does this make sense?vtrix2012-06-18 18:53:49
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests