Flippy Flappy Bird template

Discussion and feedback on Construct 2

Post » Wed Feb 12, 2014 6:21 pm

I'm sure everyone has tried this out already. :) But has anyone tried enabling animation on the bird? The bird looks fine, but doesn't 'flap'... so when you enable the animation into a 'loop' via the sprite editor, and try to run the game... does anyone else notice how it jumps all over the place?

Is this a bug... or is by design again? :)
B
47
S
15
G
3
Posts: 201
Reputation: 4,625

Post » Wed Feb 12, 2014 6:57 pm

It's because the origin point is in a different position on each frame.
B
55
S
29
G
19
Posts: 1,520
Reputation: 25,620

Post » Wed Feb 12, 2014 6:57 pm

If you see the animation sprite jumping all over the place, then it's likely because the main body in each of the frames aren't lined up.danialgoodwin2014-02-12 18:57:41
B
20
S
4
G
1
Posts: 185
Reputation: 2,563

Post » Wed Feb 12, 2014 8:03 pm

[QUOTE=danialgoodwin] If you see the animation sprite jumping all over the place, then it's likely because the main body in each of the frames aren't lined up.[/QUOTE]

Yeah, they have the origin of each frame in different spots. I wonder why that would be.... strange.
B
47
S
15
G
3
Posts: 201
Reputation: 4,625

Post » Thu Feb 13, 2014 6:25 am

Probably becuase the images were imported from a sprite sheet(s). If you never fix the origin then you'll get crazy movements and wakyness will ensue.

I've encountered this many a time, along with making sure collision polygons are set after importing.

So yeah, just "center" each frame's origin.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,816

Post » Thu Feb 13, 2014 1:09 pm

Oops, looks like a mistake in the template. Fixed for the next build.
Scirra Founder
B
387
S
230
G
87
Posts: 24,245
Reputation: 192,210


Return to Construct 2 General

Who is online

Users browsing this forum: Cliffu and 1 guest