For Each not behaving as expected

Get help using Construct 2

Post » Mon Sep 24, 2012 5:59 pm

Here is the code in question:


The issue I'm having is that although my characters move independently of each other (in different directions etc), they don't animate correctly. You can see the boolean system I'm using to trigger what state the skeleton is in; this works if there is just a single skeleton in the layout, but if I put more than one into the layout the system breaks down. It seems as if they're altering each others booleans, but this shouldn't be happening.
slap it onto the flappy bird template...
bang it on google play with all the other shovelware...
sorted...
B
36
S
7
G
4
Posts: 322
Reputation: 8,170

Post » Mon Sep 24, 2012 6:24 pm

I don't know if it's been fixed -but i'm pretty sure having groups underneath a For each condition used to break it.
See if placing one as the first event in each group fixes it
B
28
S
8
G
1
Posts: 469
Reputation: 4,683

Post » Mon Sep 24, 2012 11:17 pm

Isn't the For Each totally redundent there anyway?

Might be worth going and reading the tutorial on instance picking.

http://www.scirra.com/manual/75/how-events-work/page-1

I think there's a more detailed explanation under the For-Each bit of the manual.
B
11
S
4
G
3
Posts: 70
Reputation: 3,071

Post » Tue Sep 25, 2012 12:05 am

ImageImageImageImageImageImage
B
93
S
19
G
12
Posts: 1,209
Reputation: 18,357


Return to How do I....?

Who is online

Users browsing this forum: Magistross, zatyka and 24 guests