Fps lag with tilemap background

Discuss game development design and post your game ideas

Post » Fri Oct 31, 2014 3:17 pm

Hi everyboy!
I'm working on my game since 6 month, i have a lot of elements and animation, but a big probleme and i'm really lost...

My probleme it's about lag and fps ... i'm doing a scroll game, but when i'm loading my background the fps go down... :s
I think i try everything, but i do not find a good way... i do it in tile map (good idea?) an i want to load the background aleatory and i want it work on smartphone.

You can download the project : https://www.dropbox.com/s/lkkzdauxpk328 ... n.zip?dl=0

Hope some body help me...
Thanks a lot!!

(réponse en francais pr les francais :)
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 7
Reputation: 239

Post » Fri Oct 31, 2014 3:28 pm

I don't get any lag on my machine, but You are using tilemaps very strangely - i think you did not understand what they are for. And why do you have xxx numerbs of copies of same tilemap objects?! Please read some tutorials and "how-to"s first before you get into big troubles with your project later in development.
ImageImageImageImage
B
157
S
66
G
42
Posts: 2,603
Reputation: 35,343

Post » Fri Oct 31, 2014 4:03 pm

I have some lag when you go by right with the arrow, look with the debug expor, when i move i have 30fps...

I already read tutorial,
i use tilemap editor for edite my tilemap (more option) and i import xml in construct.
But he creat a new image of tile, maybe a way to connect then in same file....?
B
3
Posts: 7
Reputation: 239


Return to Game Development, Design & Ideas

Who is online

Users browsing this forum: No registered users and 2 guests