fps slowdown in r158?

Discussion and feedback on Construct 2

Post » Sat Jan 18, 2014 1:51 am

It's only chrome with the problem here as well.
Moderator
B
95
S
34
G
33
Posts: 3,006
Reputation: 27,874

Post » Sat Jan 18, 2014 2:53 am

yes, only chrome, and it begun when it(Chrome) upgraded to the latest version (this afternoon for me)

Firefox and IE works fine.

For C2 I also tried going back to stable r152 and nothing changed so its defenetly a Chrome issue.
B
5
S
1
G
2
Posts: 22
Reputation: 1,824

Post » Sat Jan 18, 2014 4:22 am

Uh oh, just went to "About Chrome" to see what version I have, and it's 31, but says "reboot to finish update" ack!

OMG, that is horrible. I can now use Chrome to test how my games play on Iphone 4.

http://hexedtext.clay.io/ is this playable??Paradox2014-01-18 06:29:16
B
233
S
62
G
33
Posts: 902
Reputation: 40,398

Post » Sat Jan 18, 2014 7:03 am

Not good I'm still on R153 due to a performance drop on every release since R154...

And now Chrome is running at 20-30 FPS max down from 50-60 on My current project, also will only render in canvas, rather than webGL...

Without chrome C2 HTML5 games have a major problem, as firefox does not compare performance wise...
As long as I can move left, right and fire, I'm Happy...
B
42
S
15
G
11
Posts: 655
Reputation: 12,260

Post » Sat Jan 18, 2014 7:21 am

i have been having the same issue,I downloaded Firefox and its the same as Chrome.Im glad to see im not the only one.I thought it was my computer.Im going bak to the last edition until this gets sorted out.
RookieDev2014-01-18 07:30:31
GMO FOOD = DEATH
B
23
S
9
G
5
Posts: 567
Reputation: 6,378

Post » Sat Jan 18, 2014 12:10 pm

here's what fps I get loading the simple catapult example:

Chrome:
http://i.imgur.com/iWa9qwN.png

Firefox:

http://i.imgur.com/py8xUH4.pngrujo2014-01-18 12:12:30
B
5
S
1
G
2
Posts: 22
Reputation: 1,824

Post » Sat Jan 18, 2014 4:41 pm

@Ashley Anything New on whats actually causing the slowdown?
I really was pulling my hair out thinking it was my computer.
And for the people that say the slowdown is just for chrome,Im getting the same thing just a tad less lag with Firefox.
GMO FOOD = DEATH
B
23
S
9
G
5
Posts: 567
Reputation: 6,378

Post » Sat Jan 18, 2014 4:56 pm

[QUOTE=Paradox] Uh oh, just went to "About Chrome" to see what version I have, and it's 31, but says "reboot to finish update" ack!

OMG, that is horrible. I can now use Chrome to test how my games play on Iphone 4.

http://hexedtext.clay.io/ is this playable??[/QUOTE]

on my pc your game runs smooth on firefox but extremely slow on chrome (unless i resize the window to a very tiny dimension)
B
5
S
1
G
2
Posts: 22
Reputation: 1,824

Post » Sat Jan 18, 2014 4:59 pm

OK, I think this is to do with our detection of Swiftshader. Chrome has a software WebGL renderer (called Swiftshader) for the Windows version only, and it tends to be really slow. If the graphics card driver is blacklisted then it would use that for WebGL rendering instead of the GPU. When they first released this it was really annoying for us, because it would always use the WebGL renderer even if it was software rendered and the canvas2d renderer would be GPU accelerated. So we implemented a pretty nasty hack (it could have broken at any time) to detect Swiftshader and revert to canvas2d instead. I didn't know if that would be effective, since I thought if the driver was blacklisted then surely the canvas2d would be software rendered too. I guess this is not the case and canvas2d can often be GPU accelerated where the WebGL renderer is blacklisted and using a software renderer.

Anyway in r153 we changelogged that the detection had changed. A Google developer announced that there was a new official option to avoid software-rendered WebGL (failIfMajorPerformanceCaveat). In the interest of avoiding ugly hacks and sticking to the official recommended way of doing things, we removed our own hack and started using that option instead. Turns out it's not actually supported in Chrome 32, and I've been told it should be in Chrome 33+. So until Chrome 33 all we've done is enable the software-rendered WebGL again. If you're affected, check the renderer string - I'd guess you were previously getting canvas2d and now you're getting WebGL.

This would only affect Chrome on Windows where the driver is blacklisted and the CPU is not fast enough to software render at 60 FPS. So no mobile devices affected, no desktop systems other than Windows, no other browsers, and not even most Chrome users (judging by Mozilla's stats, since they're the only ones to publish blacklisting figures, about 20% of users have blacklisted WebGL support). And as soon as Chrome 33 comes out it should suddenly get faster again, since it understands the failIfMajorPerformanceCaveat setting and should switch back to GPU-powered canvas2d.

I don't think we'll do another stable update for this - it's not a permanent problem, since even if you publish now, when Chrome 33 comes out it won't be slow any more, and only a minority of users using a specific OS + browser combination will be affected. I also don't see much point in fixing it for the next beta since by the time we make another stable release Chrome 33 should be out which will fix it anyway. In the mean time a workaround is to disable WebGL in project properties, or force Chrome to use GPU acceleration (go to chrome://flags/#ignore-gpu-blacklist and click Enable).

tl;dr - temporary blip which should be gone soon
Scirra Founder
B
397
S
236
G
88
Posts: 24,423
Reputation: 194,560

Post » Sat Jan 18, 2014 5:16 pm

glad to hear this! :)

and the temporary workaround works for me!

thank you very much
B
5
S
1
G
2
Posts: 22
Reputation: 1,824

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests