FPS Tips?

Get help using Construct 2

Post » Mon Feb 02, 2015 8:58 am

Hey guys..
I have a "problem".. maybe! : -)

I create a game.. with no to big images but no to small, no big code.

I test it in chrome and firefox and my fps are: ~60, but when i test it in safari my fps are: ~30 (I have the latest version of all browsers).
Why this? Anyone know some tip? I don't want to change my images to low quality... Maybe there is some way to fix this!

Thank you all!!!

Regards,
Kyriakos
Last edited by odiusfly on Mon Feb 02, 2015 9:46 am, edited 1 time in total.
B
52
S
32
G
14
Posts: 242
Reputation: 12,333

Post » Mon Feb 02, 2015 9:45 am

Here is a test example:

SAFARI
FPS: 22
CPU: 65%

CHROME
FPS: 60
CPU: 2%

FIREFOX
FPS: 60
CPU: 4%
B
52
S
32
G
14
Posts: 242
Reputation: 12,333

Post » Mon Feb 02, 2015 9:51 am

I'm not exactly sure, but I think safari doesn't really do WebGL right? What does the debug say?
B
19
S
6
G
6
Posts: 1,101
Reputation: 5,646

Post » Mon Feb 02, 2015 9:58 am

I noticed when i run in debug mode with chrome its says: ......... - webgl
but when i run in debug mode with safari tab says: ......... - canvas2d

Maybe, you 're right! Something wrong with webgl.
B
52
S
32
G
14
Posts: 242
Reputation: 12,333

Post » Mon Feb 02, 2015 10:09 am

I think the "problem" is in safari and webgl.. Maybe i get lower fps because i run my game with the safari under windows..

I search in google for safari and webgl and i find this:

-In Safari, open the Safari menu and select Preferences.
-Then, click the Advanced tab in the Preferences window.
-Then, at the bottom of the window, check the Show Develop menu in menu bar checkbox.
-Then, open the Develop menu in the menu bar and select Enable WebGL.


Maybe in next update for safari in windows.. have this option! : -)
B
52
S
32
G
14
Posts: 242
Reputation: 12,333


Return to How do I....?

Who is online

Users browsing this forum: brunopalermo, Google [Bot], Phacanu, richcoz81, Txchaser and 28 guests