Frusterating bug that does random things

Get help using Construct 2

Post » Fri Aug 09, 2013 6:41 pm

I have a simple flashcard making software. On start of the Home layout, if a local "decks" key exists it loads all the decks on the Home layout, but if the decks key does not exist it creates it and sets its value to "Default|" and then it continues to load all the decks on the Home layout (which is now only the Default deck).

When i clear my cookies (meaning that the decks key does not exist), the Default deck still shows, which means that the application successfully detects that the key does not exist so it creates "decks" = "Default|" and then populates the home screen with the deck.

When you click a deck, a variable deckname is set to the value of the name of the clicked deck. Then you go to another layout where the cards of that deck are shown. If a local key with the deckname does not exist (which means that no cards have been added to this deck yet) then it displays a text which says "no cards added." However if a key called deckname does exist, it will populate then screen with the cards.

The frusterating bug is, that SOMETIMES when i click the default deck it'll say "no cards" and sometimes it'll just display no text. If i keep rerunning the app without making any changes at all, sometimes it'll say "no cards" and sometimes nothing. This makes absolutely no logical sense why it should be doing this so i am assuming it is a bug?

I am attaching the capx.
http://www.qfpost.com/file/d?g=ruuoLAVDI
B
11
S
4
G
2
Posts: 20
Reputation: 1,412

Return to How do I....?

Who is online

Users browsing this forum: DJKeefy, Momio, oddreal and 8 guests