Fx sound audio delay in android

Discussion and feedback on Construct 2

Post » Mon Dec 08, 2014 8:59 pm

Hi.

I have a problem when export a game to android crosswalk. The fx sound play delay to 0.5 second. In browser Mobile work fine (chrome).

What is the problem?

Thanks
B
4
S
1
Posts: 25
Reputation: 400

Post » Tue Dec 09, 2014 1:26 am

Set preload sounds in C2 project properties.

Also queue a preload action in the events just in case, on start of stage or level, preload the sounds you need. So when it plays, its instant, otherwise the first time a sound is played, it has to retrieve it causing a 0.5s delay.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,616

Post » Wed Dec 10, 2014 12:21 am

Thanks for your reply.

I preload in proyect and all sound in layouts (attachment image), but the delay of 0.5 seconds still present,
What can it be?

In the same cell from chrome does not that delay.

Thanks!!
You do not have the required permissions to view the files attached to this post.
B
4
S
1
Posts: 25
Reputation: 400

Post » Wed Dec 10, 2014 1:28 pm

Crosswalk is a few versions behind Chrome (the browser is currently v39, I think Crosswalk is more like v36). It may be that just waiting for the next Crosswalk update will resolve this.
Scirra Founder
B
400
S
237
G
89
Posts: 24,550
Reputation: 195,537

Post » Wed Dec 10, 2014 4:44 pm

There isn't solution for the problem? :(
B
4
S
1
Posts: 25
Reputation: 400

Post » Fri Jan 02, 2015 3:12 pm

I'm waiting for next updates to resolve this delay issue.
B
13
S
1
Posts: 98
Reputation: 885

Post » Thu Jan 08, 2015 1:30 pm

I have the same problem. Audio is fine with other games i made, but the last one has about 1sec audio delay when i built the apk with crosswalk. Tried preloading sounds and other weird stuff, nothing.
No problems until the build. Even emulate in crosswalk is running fine.
B
9
S
1
Posts: 12
Reputation: 509

Post » Mon Jan 12, 2015 10:14 pm

I have this problem too, about 0,5 sec lag after build and no matter via IntelXDK or Cocoonjs :(
ImageImageImage
B
47
S
18
G
3
Posts: 164
Reputation: 5,336

Post » Mon Jun 22, 2015 9:37 pm

I assume this hasn't been fixed yet? It's stopping me from releasing my game!
B
7
S
1
Posts: 33
Reputation: 489


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests