FYI issue on Construct.net

All closed bug reports are moved here.

Post » Tue Mar 28, 2017 2:46 pm

I'm using Chrome ver 52 on a laptop. I know it is not the latest and incompatible with C3. However I'm at work and cannot update. So I wanted to try anyway. https://editor.construct.net/ fails gracefully with a kind error message that my browser should be updated.

Construct.net gave me the error below. Not sure if this helps but thought I would inform you. Thanks!

Critical error

This should not of happened. Please contact support.

System.ArgumentException: An item with the same key has already been added. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add) at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer) at C3.Code.Caching.CityCaching.<>c__DisplayClass1_0.b__0() at C3.Code.Controls.Application.Caching.Manager.Manager.Get[T](String key, Func`1 getFromExternFunction) at C3.Code.Caching.CityCaching.GetCityID(Int16 countryID, String cityName) at C3.Code.Helpers.GeoIP.Functions.GetCityID(Nullable`1 countryID, String cityName) at C3.Code.Helpers.GeoIP.Functions.LookupIP(String ipAddress) at C3.Code.Caching.GeoIPLookupCaching.<>c__DisplayClass0_0.b__0() at C3.Code.Controls.Application.Caching.Manager.Manager.Get[T](String key, Func`1 getFromExternFunction) at C3.Code.Caching.GeoIPLookupCaching.GetIPDetails(String ipAddress) at C3.Code.Helpers.SEO.Functions.GetUsersIPRegion() at C3.Pages.Master_Pages.Global.Page_Init(Object sender, EventArgs e) at System.Web.UI.Control.OnInit(EventArgs e) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Control.InitRecursive(Control namingContainer) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
B
28
S
5
G
2
Posts: 41
Reputation: 2,445

Post » Tue Mar 28, 2017 2:56 pm

Thank you, looking into this now.
Image Image
Scirra Founder
B
160
S
41
G
34
Posts: 4,386
Reputation: 53,509


Post » Tue Mar 28, 2017 3:24 pm

It's working now. I had the same problem.
B
24
S
12
G
11
Posts: 260
Reputation: 7,883

Post » Tue Mar 28, 2017 3:34 pm

Glad to hear it thank you!
Image Image
Scirra Founder
B
160
S
41
G
34
Posts: 4,386
Reputation: 53,509

Post » Fri Mar 31, 2017 3:49 am

apologies - didn't get a chance to follow up until now. yes all looks good. thanks!
B
28
S
5
G
2
Posts: 41
Reputation: 2,445


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests