Game behaves weird in Arcade but fine as website

If you have found a bug, or have a suggestion/comment then leave it here

Post » Tue Aug 13, 2013 10:26 pm

Hi there! I uploaded a copy of my game to the Arcade after testing it in various browsers as website, but I see that in Arcade:

* touch directions are not working (select/start/a/b work)
* when a new game is started the pieces are not falling

This is the link to the game hosted in my website:
http://andreabianco.eu/games/constructris1.2/

And this is the game on Arcade:
http://www.scirra.com/arcade/puzzle/5401/constructris

I tried to understand what is going on for a couple of hours already and while I don't give up I would appreciate some help :) Does anyone have a clue about what is going on? I am not using any third party plugin, I removed all webgl effects. I'm stuck because as I said the game works as expected in browsers, even when opened on android/wp8 browsers (well it's still needing some optimizing to be more playable and responsive on mobile, but it works).

Thanks in advance,
Andrea.
B
12
S
4
G
1
Posts: 30
Reputation: 2,660

Post » Wed Aug 14, 2013 8:47 pm

Since no one answered, I answer myself (somehow). I just downloaded the beta r141 and compiled again my game and uploaded it to Arcade.. you know, just in case ;) and guess what, the game now works! At least here. I wonder what was the problem and if r141 really fixed things or it was a server issue that got fixed in same moments.. whatever, I just hope the game will keep working ahah.

So please go, have fun and rate me good if you think the game is nice :)

Link: Constructris

Andrea.
B
12
S
4
G
1
Posts: 30
Reputation: 2,660

Post » Wed Aug 14, 2013 11:24 pm

you should update the name to "solved"

cheers :D
B
43
S
12
G
6
Posts: 446
Reputation: 6,802

Post » Thu Aug 15, 2013 12:51 am

[QUOTE=rublev1360] Since no one answered, I answer myself (somehow). I just downloaded the beta r141 and compiled again my game and uploaded it to Arcade.. you know, just in case ;) and guess what, the game now works! At least here. I wonder what was the problem and if r141 really fixed things or it was a server issue that got fixed in same moments.. whatever, I just hope the game will keep working ahah.

So please go, have fun and rate me good if you think the game is nice :)

Link: Constructris

Andrea.[/QUOTE]

It is well-known, at least by me, that games or certain behaviors or whatever behave differently between the preview browser and in the arcade. I'm guessing it has something to do with iframe?!?
B
33
S
7
G
8
Posts: 312
Reputation: 8,528

Post » Thu Aug 15, 2013 11:31 am

Hi Manley23, I did read some of your posts recently and I agree with you :)

The Arcade is such a great idea, I really hope they will make it better. About C2 made games, I am seriously considering only targeting Chrome and desktop for the new game I'm working on!

In meantime I am working to port Constructris to Android/iOS/WP8, it's part of the test I had in mind (developing a simple full functional game and port it to various platforms).
B
12
S
4
G
1
Posts: 30
Reputation: 2,660


Return to Website Issues and Feedback

Who is online

Users browsing this forum: No registered users and 2 guests