Game crashing for unknown reason

For questions about using Classic.

Post » Thu Jul 28, 2011 4:41 pm

I've been working on this one engine, and well, whenever i try to run it, it crashes! So i tried and exausted every possibility to solve the glitch, and i did manage to figure out what was causing the crashes.... That one group of events that happens to be crucial for the engine's working -.-
Sooo... I think the best way to solve this is to have someone more intelligent/experient than me (Read: Anyone) look at my .cap file and tell me what is wrong...
Here:
Stuff.cap
B
2
G
2
Posts: 19
Reputation: 688

Post » Fri Jul 29, 2011 1:18 am

Well, I've had a quick look and it's only the "positions sensors (see sub events)" event that causes the problem, not the whole group. I'll keep looking to see what the problem is within that loop.
"Construct 4 lets YOU make advanced games! (maybe)" Construct Classic - Examples Kit
B
86
S
28
G
13
Posts: 2,092
Reputation: 15,009

Post » Fri Jul 29, 2011 4:53 am

Cool, thanks man!
B
2
G
2
Posts: 19
Reputation: 688

Post » Sat Jul 30, 2011 7:23 pm

Change the "is overlapping" conditions in events 57, 58 ang 59 to "is overlapping at offset (0,0)" and it will stop crashing. This solution was found by trial and error as your events logically have nothing wrong with them.

Also your curved slope object probably needs to be a sprite, because tiledbackground objects don't have perpixel collisions.
B
79
S
24
G
52
Posts: 4,723
Reputation: 39,709

Post » Sun Jul 31, 2011 10:37 pm

Yup that did the trick! Thanks!
Also, might as well use the same topic to ask another question:
So, i managed to get the "X" movement (X is in quotes because, well, it doesn't really lock to X) now i'm trying to implement gravity and stuff, and it doesn't seem to be working all that well, the gravity seems to work all right, but i can't seem to get the character to jump, when i press the key (with debug on) the values seem to change for a fraction of a second and than go back to 0... I'm pretty sure this is some kind of basic mistake, and i'm just too stupid to figure it out on my own... So... Help, please?
Cap2.cap
B
2
G
2
Posts: 19
Reputation: 688


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests