Game Crashing on Load in Mobile Web Browsers

Get help using Construct 2

Post » Mon Nov 14, 2016 9:41 pm

Hey everybody,

Whenever somebody tries to load my game on an iPhone or an Android, the game crashes after the loading bar (in Chrome I get the "aw snap" page). Seems to consistently work fine on desktops though.

Does anyone know how I could go about debugging this? Or what might be a cause of the problem? It used to work fine but at some point during updates it started having issues, and I unfortunately wasn't testing mobile devices each update so I can't pinpoint what the change was.

Let me know if you have any ideas. Thanks!
B
4
Posts: 5
Reputation: 214

Post » Sat Dec 10, 2016 2:44 pm

If you are using a registered version, disable the splash and progress loader then try again. Since that is where the crash is happening, remove that first. If the problem persists, try Google's advice here: https://support.google.com/chrome/answe ... ktop&hl=en
You say that the game works on desktop but not on phones since updates. Has the game become so huge that you have run out of memory?
I guess I would probably start working backwards if I were you. Make a copy of your capx and start removing code that was added recently and retest until it works again. Its a pain but might be the best way to debug. If you need a quick way to test on android, there's a 99 cent app on Google Play called 'HTML5 Loader' it might help save some time since it will run the project without compiling to APK and installing.
B
5
Posts: 2
Reputation: 679


Return to How do I....?

Who is online

Users browsing this forum: Cubeeo and 40 guests