Game doesn't want to load

Discussion and feedback on Construct 2

Post » Sat Mar 30, 2013 12:57 am

Are there other reasons than missing file / bad 3rd party plugin that would cause an exported HTML5 file not to load?

I'm getting the following error in the Chrome console:

Application Cache Error event: Resource fetch failed (-1)
Uncaught Error: SecurityError: DOM Exception 18

But for a different file every time I hit refresh (clicking on the link will load whichever file is claimed to be missing without any problems)

I'm in the Dropbox public folder, previous HTML5 exported versions have worked fine, pretty sure all the files are uploaded, and the preview for this capx works.

B
9
S
2
Posts: 58
Reputation: 1,416

Post » Sat Mar 30, 2013 5:00 pm

If you're hosting on Dropbox, either you didn't upload all the files, or didn't make them all public.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574

Post » Sat Mar 30, 2013 5:29 pm

Ok, I don't think this is true. Attaching a sample capx that has the same problem. It's in my public folder, the folder shows fully uploaded (green checkmark), and clicking on the link in the console error loads the file on my browser no problem. It's also suspect that a different file is generating the error every time I refresh.

Sample capx
http://db.tt/osZpTsJf

Sample html
http://db.tt/TmFn9yi4

Edit: SpellingAgni2013-03-30 17:34:12
B
9
S
2
Posts: 58
Reputation: 1,416

Post » Sat Mar 30, 2013 6:23 pm

So after spamming refresh a lot and watching the console (since it was erroring on a different file every time, I assumed it was caching them or something), the game does eventually load.

Is this a case of Dropbox showing something is uploaded before it is or is there something else wrong? (note it was still not loading ~1 hour after exporting to my public folder)
B
9
S
2
Posts: 58
Reputation: 1,416


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests