Game not working on Huawei phones

Get help using Construct 3!

Post » Tue Jul 18, 2017 10:30 am

Hi folks

So I made two mobile games already. They work on all the phones I have tested on except for two: a Huawei P8 lite and a Huawei P9 (coincidence that they're both Huawei?). The game installs fine (so it isn't an untrusted sources problem), but when we try to launch the game, it just gets stuck on the loading screen. What am I doing wrong? Is it a bug in my game or in Construct 3?

Here is a link to my c3p: https://drive.google.com/open?id=0B4VhsizTyhDHLXJwUl9yVE85NVU

And here is a link to the apk (debugging mode): https://drive.google.com/open?id=0B4VhsizTyhDHSGFNUElLamNkWFk

I tried playing around with the settings (minify script, debugging and release mode, etc)

I would really like to know what kind of issue this is, because I want to get to a point where I can try and publish my games on the play store.
B
13
S
4
Posts: 25
Reputation: 867

Post » Wed Jul 19, 2017 9:20 am

Hi there,

I've got a Huawei P10 Lite and it runs here. I can't make the bat moving (I tap to the left or to the right but nothing happens). Don't know about the P8 Lite but I can say that the game launches on P10 Lite.
B
14
S
4
G
2
Posts: 61
Reputation: 2,536

Post » Wed Jul 19, 2017 10:34 am

The bat isn't supposed to move. When you press left or right there is a force pushing the ball. So you're controlling the ball, not the bat.

Still, I really appreciate the feedback! Now I know it's probably something on the devices, not my game.
B
13
S
4
Posts: 25
Reputation: 867


Return to How do I...?

Who is online

Users browsing this forum: No registered users and 1 guest