Game pausing?

Discussion and feedback on Construct 2

Post » Wed Sep 30, 2015 10:34 pm

Hi.

I've been following a breakout tutorial and the game is working great but it keeps pausing for like 3-4 tenths of a second and the ball freezes in flight and the fps go to almost 0.

is this a bug or does someone know whats going on? its ruining the game which was starting to be really fun.
B
6
S
1
Posts: 73
Reputation: 556

Post » Thu Oct 01, 2015 3:48 am

I've seen this recently in my own tests, and - for me - it's been down to the destruction of Flash player by most browsers.

Make sure you don't have a tab open with a Flash advert on it (which means almost any advert, because a lot of them cycle content and occasionally still throw a Flash ad into the mix), while the browser is deciding that it doesn't want to play Flash any more, it pauses everything for a fraction of a second... very annoying. Seen in Chrome and IE11 on Windows 7 Home.
B
5
Posts: 17
Reputation: 259

Post » Thu Oct 01, 2015 7:05 am

What system / browser(s) are you testing on?

Have you tried disbling the addons?

Is there anything showing in the browser console?

Is it possible to upload a .capx here or provide a link so we can test it also?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,414
Reputation: 59,512

Post » Thu Oct 01, 2015 9:55 am

InsaneHero wrote:I've seen this recently in my own tests, and - for me - it's been down to the destruction of Flash player by most browsers.

Make sure you don't have a tab open with a Flash advert on it (which means almost any advert, because a lot of them cycle content and occasionally still throw a Flash ad into the mix), while the browser is deciding that it doesn't want to play Flash any more, it pauses everything for a fraction of a second... very annoying. Seen in Chrome and IE11 on Windows 7 Home.


I use an ad blocker to get rid of those vile things ;)
B
6
S
1
Posts: 73
Reputation: 556

Post » Thu Oct 01, 2015 9:59 am

zenox98 wrote:What system / browser(s) are you testing on?

Have you tried disbling the addons?

Is there anything showing in the browser console?

Is it possible to upload a .capx here or provide a link so we can test it also?


System: 6 core 3.6ghz CPU, 16gb ddr3 ram, GTX 770 2gb GPU, SSD hard drive.
Browser: Firefox

Do you mean browser addons? The only one I think I have is an ad blocker, I don't see how/why that's affecting it but I will try disabling it. As for browser console I'm sorry, I don't understand what you mean :(

Well the game is the breakout tutorial from this site, I would upload the file if I knew how to do it. But I don't think I do. Sorry
B
6
S
1
Posts: 73
Reputation: 556

Post » Thu Oct 01, 2015 10:26 am

Do yet see any stuttering or jank when testing the in-built demos, such as the ghost shooter example?

For reference, I use firefox and the built-in ghost shooter rain example runs steadily at 60 fps, so I'd expect your system not to jank when testing.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,414
Reputation: 59,512

Post » Thu Oct 01, 2015 10:36 am

zenox98 wrote:Do yet see any stuttering or jank when testing the in-built demos, such as the ghost shooter example?

For reference, I use firefox and the built-in ghost shooter rain example runs steadily at 60 fps, so I'd expect your system not to jank when testing.


Nope, that demo is butter smooth.
B
6
S
1
Posts: 73
Reputation: 556


Return to Construct 2 General

Who is online

Users browsing this forum: Google [Bot] and 17 guests