Game Previewing Error

Bugs will be moved here once resolved.

Post » Fri Jan 23, 2015 12:26 am

Problem Description
whenever i try to preview my created game i keep getting an error message pop up and says

The page at localhost:5000 says

Javascript error!
Uncaught InvalidStateError: Failed to
execute 'drawImage' on
'CanvasRenderingContext2D': The
HTMLImageElement provided is in the
'broken' state.
http://localhost:5000/preview.js, line 1786 (col 11)

This is likely a bug in Construct 2 or a third
party plugin or behavior - please report it to the developer. Subsequent errors will be logged to the console.

Attach a Capx
____ Upload a Capx to this post ____

Description of Capx
____ Concise description of what this CapX does ____

Steps to Reproduce Bug
  • Step 1
  • Step 2
  • Step 3 etc.

Observed Result
____ What happens? ____

Expected Result
____ What do you expect to happen? ____

Affected Browsers
  • Chrome: (YES)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack[/b
windows 8

[b]Construct 2 Version ID

construct 2 r 195
B
3
Posts: 4
Reputation: 183

Post » Fri Jan 23, 2015 8:51 am

Why have you posted an exact copy of an already open bug report?

Ashley is the only developer, so it can take him a while to get around to fully examining the numerous bug reports he gets.

Plus, you are still not following the guidelines, so Ashley will more than likely automatically close this anyway.

This is obviously a problem with your system, but you are not giving any helpful information that can guide others to help you.

Have you updated you gfx drivers?
Have you tested on all browsers? (important, as if it works on say FF and IE, then it more than likely a chrome issue).
What does the browser error console say?
Have you always had this issue, or was it OK with a previous build of C2?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
132
S
29
G
81
Posts: 5,329
Reputation: 56,657

Post » Tue Jan 27, 2015 5:57 pm

Closing as can't reproduce. Since nobody else is reporting the problem it's probably specific to your system. Try disabling any browser addons you have or testing another browser.
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,464


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest