Game speed over Time?

Get help using Construct 2

Post » Sun Sep 08, 2013 11:24 am

Hey Guys, I've hit a brick wall. Using the autorunner template I'm trying to create a fun lil autorunner that will increase speed gradually over time. I added this, which I thought would do the trick:

System - every: 5 seconds - tiledblock : bullet speed : "block.Bullet.Speed+20"

I thought that would work, but the problem seems to be that when the tiles are generated again, they return to their default values, so it will only speed up if the block is active for 5 seconds on screen, then it returns to -20 again when the new block is created.

hope that makes sense, I would really appreciate anybody's help on how to fix this.

https://dl.dropboxusercontent.com/u/51560464/Autorunner/Autorunner_probs.capx
B
4
Posts: 9
Reputation: 394

Post » Sun Sep 08, 2013 11:35 am

Craete a global variable blockspeed and set it to the initial bullet speed.

System - every: 5 seconds - system : add 20 to blockspeed
                            block : set bullet speed to blockspeed
on block created - block : set bullet speed to blockspeed

LittleStain2013-09-08 11:36:06
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sun Sep 08, 2013 4:06 pm

@LittleStain it seems so simple now!!! thx a lot littlestain!
B
4
Posts: 9
Reputation: 394

Post » Sun Sep 08, 2013 4:10 pm

No problem!

I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 7 guests