GameJolt Upload Issue

Discussion and feedback on Construct 2

Post » Tue Sep 15, 2015 11:16 pm

So I've uploaded 4 games previously on GameJolt with out issue. Now our new game Kitty Pot Cracker Worlds for some reason wont upload at all, it just resets the upload build screen after it hits 99%. GameJolt told me that the index file should be the only file in the root but when you export for HTML5 sites Embed style the root has the index and other files. I tried moving the other files to another folder. It then uploads but displays a black screen.
This is my first time using a loader layout, could this be the problem?
If anyone has any idea please let us know, thanks!
ImageImage
B
44
S
10
Posts: 323
Reputation: 3,202

Post » Mon Sep 21, 2015 12:14 pm

Same here, in the past I've already put my games on GameJolt but this time it returns an error when is loading the C2Runtime
Here the game for see the error http://gamejolt.com/games/notzilla-icec ... ndor/92959
Luca ConTato [RisingPixel]
Image
B
22
S
8
G
2
Posts: 118
Reputation: 2,911

Post » Tue Sep 22, 2015 9:59 am

It seems something relate to cross domain request?

Image
Luca ConTato [RisingPixel]
Image
B
22
S
8
G
2
Posts: 118
Reputation: 2,911

Post » Tue Sep 22, 2015 2:39 pm

@tatogame OK cool, maybe @Ashley can figure it out?
ImageImage
B
44
S
10
Posts: 323
Reputation: 3,202

Post » Tue Sep 22, 2015 4:28 pm

It looks like the server is returning 403 forbidden for a bunch of your files. So something about the server configuration is wrong. If it's on GameJolt's server, you need to talk to GameJolt about it.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095

Post » Tue Sep 22, 2015 6:34 pm

I could be wrong but if the root has the index and files all in one when you move them the path is changed so the code for the game can't find it. That is why you have a black screen. Basically when you moved them to the folder you would have to update all the files path information.

IE
If the index looks for screen.png but you moved it to new folder/screen.png so can't find it.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Tue Sep 22, 2015 7:02 pm

I never used the c2 embed export I just exported as a regular site
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Post » Wed Sep 23, 2015 9:16 pm

Heya, I've looked into it a bit and found that construct uses anonymous crossOrigin requests to load textures and other resources. This means that the cookies that GameJolt set which allow you to access the files you need dont get sent and if the remote endpoint you're trying to load from doesnt have em cached for your client you're going to end up with 403's. I suggest if its possible to try and replace all the "anonymous" crossOrigin settings to "use-credentials" and check again.

P.S. A cool feature for construct would be to allow you to choose the profile for cors requests.
B
3
Posts: 5
Reputation: 185

Post » Thu Sep 24, 2015 9:07 am

Same problem here. I've not been able to upload any game to gamejolt since they updated the web. Anyone knows what it needs to be done?
B
12
S
2
G
1
Posts: 32
Reputation: 756

Post » Thu Sep 24, 2015 12:28 pm

I tested by using the Kongregate export option, zipped it up and it worked fine on GameJolt. Test published and it loaded right up. So use export to Kongregate.
B
23
S
4
G
2
Posts: 364
Reputation: 2,392

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests