gamepad not working with NodeWebkit preview

Discussion and feedback on Construct 2

Post » Wed Jan 08, 2014 7:00 pm

Ok, thank you for the input. I'm really stumped then. All my drivers are up to date and I've done a clean reinstall of construct 2 with no effect. I did more testing in debug mode with events that for example when you press A on the controller a global variable changes. It's just not accepting any input at all in node-webkit preview or export but it's working in chrome when I do the exact same thing. It's also concerning that I replicated the results on 2 different computers. Maybe I'll go pick up another controller and see if it will make any difference.
B
62
S
20
G
57
Posts: 1,077
Reputation: 36,531

Post » Fri May 09, 2014 11:08 pm

i have the same issue too win 7 C2 32x

but i'm using a xingling ps3/pc gamepad; it works with the chrome preview but not with the node-webkit :/
B
50
S
5
G
6
Posts: 210
Reputation: 6,357

Post » Tue May 26, 2015 2:04 am

There is definitely an issue with node-webkit / nw.js with gamepads and Windows 8.1 specifically. The gamepad API will work fine in Windows 7 and OSX with nw.js. It will also work fine in the Google Chrome browser in Windows 8.1. There's just a problem specifically with nw.js and Windows 8.1 where the Gamepad API will not show any connected gamepads.

I finally figured out the fix! I wanted to post it here because I found this thread while looking for a solution to this problem. You just need to install the Windows 7 driver for the xbox 360 controller.

Unfortunately, since this is my first post here (I'm doing it as a public service) the forum is not letting me give you direct links to the Microsoft drivers.

But you can find them at:

microsoft dot com slash hardware slash en-au slash downloads#gaming

Good luck!



Burvey wrote:I'm using an XBox360 controller along with the gamepad object. When I preview my game using Chrome it works perfectly but when I try to preview in NodeWebkit (which is what I'm developing for) it doesn't work. It's like the gamepad isn't detected or something. Any ideas?

EDIT: I've added a simple capx file. If anyone is using windows 8.1 could you please test this and let us know if you get the same result. Thank you. 18:15:06
B
2
Posts: 1
Reputation: 152

Post » Tue May 26, 2015 2:47 am

Haven't had to do this with mine... W8.1 and all NW versions from 10.5 to 12.1 have worked fine.... Genuine Xbox controller for me, in case that might be the problem?
Learning other engines, but C2 still rocks. Image Image Image Image
B
81
S
22
G
96
Posts: 2,468
Reputation: 58,353

Post » Sat Apr 02, 2016 8:18 pm

Same issue here with Windows 10 and NW.js 0.13.

Gamepad worked perfectly in a computer which was running W7 before and then upgraded to W10. Maybe the X360 drivers are not updated when you upgrade from W7 to W10.
On a laptop with a "fresh" W10 install, I had to install W7 drivers (thanks for the tip, zachstronaut !) to get the gamepads to run.

This is really annoying as you can't ask a user to install W7 drivers if they're running W10. I hope this problem will be solved soon. I can't release my game with such a bug.
B
8
S
4
G
5
Posts: 37
Reputation: 2,826

Post » Sun Apr 03, 2016 7:10 am

I'm not occurring issues with the gamepad controls in NW.js 0.13, C2 r226 beta and Windows 10.

I don't have an Xbox 360 controller, but I emulate it using x360ce, with a Chinese-made PlayStation controller. ;)
SONAR Gamer's Club Discord |
Twitter | Facebook | Instagram

If you play Puyo Puyo games, you can meet me at the Puyo Puyo English Community Discord: https://discord.gg/0k41S8ARwvY2iTIQ
B
111
S
27
G
11
Posts: 703
Reputation: 13,225

Post » Mon Nov 28, 2016 5:43 am

I experienced the following problem running Windows 8.1 and Construct 2 Release 269 64Bit and nwjs-for-c2-v0-18-1:
My XBox 360 USB controller was only being recognized when I ran the game in "Debug Mode."

I didn't have this problem prior to upgrading to nwjs-for-c2-v0-18-1.

FIX: I upgraded to nwjs-for-c2-v0-18-7 and it seems to be resolved.
B
4
Posts: 1
Reputation: 202

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 2 guests