Games won't open.

Bugs will be moved here once resolved.

Post » Sun Mar 25, 2012 1:43 pm

This isn't a bug, but, wasn't sure where else to post this.

I've started the beginners tutorial and nothing seems to run even if I try the example files they won't play. I have tried it with firefox 10 and iexplorer. I Even updated firefox to 11.0 and have the same issue.

When I hit play a browser pops up and I see localhost.com:50000 as the URL, and eventually it times out. I tried turning off my firewall and still have the same issue.

I'm using a windows 7 pc and as I mentioned now I am using firefox version 11.0.

Anyone have any idea how to get past this?
B
4
S
2
G
3
Posts: 5
Reputation: 2,187

Post » Sun Mar 25, 2012 6:51 pm

Are you sure there are no other servers running on your computer that block Construct 2's server? Does changing the preview port in Preferences help? Does it work if you enable the Preview-on-LAN feature but just run locally?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Mar 25, 2012 7:37 pm

Thanks for the reply.

I have tried to change the server to 50100, turned off my antivirus, and am only running one version of iexplorer and firefox. I've closed most other programs in task manager.

I have also tried to run in admin mode with no effect. The preview on lan feature is greyed out for me because I have a free version.

*edit*
One last thing I run through a router, but, my brother has no issue on his pc, so it shouldn't be a router issue. zenprophet2012-03-25 19:40:22
B
4
S
2
G
3
Posts: 5
Reputation: 2,187

Post » Sun Mar 25, 2012 11:02 pm

@zenprophet I'm afraid I'm not sure what the problem could be - it may be your computer's configuration, or there may be some way to work around it in C2, but it's hard to tell. Perhaps as a last resort you could try setting the Preview Mode in Project Properties to 'File'. This skips the server entirely and just loads a file on disk, but modern browsers have such strict security limitations on files on disk often they just won't run. For that reason we have the feature deprecated since we hope to remove it, but it might give you at least something to work with for the time being.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sun Mar 25, 2012 11:24 pm

Thanks for the reply Ashley.

Setting project properties to file worked. I'll download a fresh copy of chrome and will not import any settings and just let it do a default install. If I find the answer in my browser settings I'll post it here or somewhere else for others that might run into this issue.

Thanks again.
B
4
S
2
G
3
Posts: 5
Reputation: 2,187

Post » Mon Mar 26, 2012 12:00 am

Update.

I downloaded chrome and tried it out, but, I get an error that it can't launch chrome. I tested with opera, firefox, ie, chrome again with no luck. However if I paste "localhost:50100" into an opera browser it works fine.

The game doesn't launch, but, if I put localhost:50100 in the address bar I can preview my games in opera.
B
4
S
2
G
3
Posts: 5
Reputation: 2,187

Post » Mon Mar 26, 2012 3:44 am

I had the same problem in my girlfriend's notebook during the Global Game Jam this year. It was a brand new Asus N53S. I tried everything and couldn't get it to work. In the end we used the file preview as a last resort.
Scirra Employee
B
129
S
45
G
15
Posts: 705
Reputation: 15,413

Post » Mon Mar 26, 2012 11:19 am

7 premium ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Wed Mar 28, 2012 6:47 pm

Sorry for the slow response. Yes windows 7 premium is the os I'm using. Seems to work fine in opera, but, it won't open up a tab or browser I have to have opera up already and paste in localhost:50100. But, it's working for me this way.
B
4
S
2
G
3
Posts: 5
Reputation: 2,187

Post » Thu Mar 29, 2012 4:13 am

[QUOTE=Kyatric] 7 premium ?[/QUOTE]Yes, Win7 Premium indeed. What`s wrong with it?
Scirra Employee
B
129
S
45
G
15
Posts: 705
Reputation: 15,413

Next

Return to Closed bugs

Who is online

Users browsing this forum: Kenthria and 4 guests