get music to play on android chrome or ios 6?

Get help using Construct 2

Post » Wed Jul 24, 2013 4:09 pm

I have imported ogg and m4a versions of some music and one sound effect.

set the music to play with a loop on start of layout.

The sound effect happens when you tap the screen.

On Chrome on the desktop, it works great.

On Chrome on Nexus 7, I get no music, and the sound effects are out of sync, e.g. tap once, get good sound, tap immediatly a second time, a long delay before it plays the effect again. If I tap lots of times, I sometimes get one sound, sometimes a second after a long delay.

On iphone 4, ios 6, I get no music, but the sound effects are perfect, if I tap 3 times quickly, I get 3 sound effects quickly.

The exported project is here

nutmix2013-07-24 17:26:59
B
17
S
6
G
3
Posts: 370
Reputation: 3,942

Post » Wed Jul 24, 2013 4:15 pm

For the delay: use "trigger once" command when you play the sound effect.
For the music I do not know. I use CocoonJS to export and use my game on Nexus 7 and the music play ok.
B
13
S
4
G
1
Posts: 74
Reputation: 1,230

Post » Wed Jul 24, 2013 5:20 pm

Tried adding trigger once, didnt make any difference, unfortunately. so sound effects play correctly on chrome desktop and safari ios, but are broken on Android Chrome on Nexus 7. (and neither mobile will play music)

I think the nexus is only playing the first and last if you request the same sound effect several times, and between the first and last, is a big pause. So if I tap 5 times, I get the first sound effect, a pause for 3 sound effect durations, then the final sound effect very much late.

The exported project is herenutmix2013-07-24 17:26:39
B
17
S
6
G
3
Posts: 370
Reputation: 3,942


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 10 guests