Glitches while pinned..

Get help using Construct 2

Post » Fri Jul 20, 2012 7:41 am

Hello,

I am very new at this stuff, so be easy on me.

I have attached my capx file dropbox link below. I'm having a couple problems with behaviors when objects are pinned to each other.

The player, called 'The Pusher' in the game, pins to objects called 'containers'. I have had help in trying to sort out the custom movement that was needed when they are pinned. It's 'kind of working'....

My issues are:

1. Sometimes when they become pinned (by pressing the spacebar), it appears that 'The Pusher' is too close to the 'container' and the glitchy, slow, stutter step starts until they are unpinned.

2. Another similar problem is that, while pinned, when 'The Pusher' backs into another solid object, a glitchy, slow, stutter side step ruins the vibe pretty quickly.

3. Last, but not least, when they are pinned and the 'container' is being pushed into a collision with another container or a wall, they become unpinned and the 'container' is stuck! You have to pin multiple times and press in the opposite direction to unstick it. I was having more trouble with this originally because when the 2 were pinned after the 'container' was stuck, I could re-pin and march the 'container' right through a wall that it was stuck to, aaaahhh. Somehow, applying the 'car movement' behavior without default controls mended that problem. In a perfect world, the 'container' would just stop and not unpin on collision with other solid objects. It should stay pinned until prompted to unpin via the spacebar.

Could someone please help me with these problems. I realize that the way things are on my event sheet right now may be incorrect for what I want to accomplish.

Any help is much appreciated!!! Thanks in advance.

https://www.dropbox.com/s/x1641u7pxmuzsvx/ThePusher%20Edited.rar?mHighPockets2012-07-20 07:43:47
B
4
Posts: 18
Reputation: 811

Post » Fri Jul 20, 2012 9:35 am

Problem 2 is caused by uneven collision boxes on the walking animation. If you straighten up the collision box and 'apply to all animations' it fixes that.ramones2012-07-20 09:44:55
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,020

Post » Fri Jul 20, 2012 9:17 pm

That worked great ramones!! Thanks a mill!

It actually solved issue's 1 and 2, but now I noticed another glitch when the container objects collide with another solid object, sometimes they bounce a couple pixels to the side..?? I imagine that this has something to do with the collision polygon, but I've had no luck so far. The containers are simply square and they only collide with other square objects...

Can anyone help with issue number 3 and my new collision problem??

Thanks again for your help ramones!!
B
4
Posts: 18
Reputation: 811


Return to How do I....?

Who is online

Users browsing this forum: Google [Bot], GSquadron, HTB and 26 guests