go to layout jumping to wrong layout!?

For questions about using Classic.

Post » Sun Jul 05, 2015 2:59 pm

Hi again everyone!

I just got my main game logic cycling from title layout (1), character select layout (3) , main game (2), then to continue or quit (6), then back to title (1) if quit.

Now, the weird issue is, that after I go from the title(1) to character select , the character select layout (3) should go to layout 2 as always.. but - it doesn't, it goes to title (layout 1).

This only happens on the second playthrough of the game loop, the first time around its fine... there are no other events in that layout to take me back layout 1..

so confused by this - can anyone help?

*UPDATE*

on further examination, I was testing the LAYOUT object - and this might be causing the issue , deleted it and tried a quick jump back to title with it deleted and it was OK - I guess this is one of the bugs?
B
11
S
4
G
5
Posts: 171
Reputation: 2,446

Post » Sun Jul 05, 2015 6:24 pm

Could be. The layout object is a little dodgy.
B
92
S
32
G
109
Posts: 5,290
Reputation: 70,991

Post » Tue Jul 07, 2015 10:47 am

is the layout object source contained within the editor? we can't seem to find the source for it...
B
11
S
4
G
5
Posts: 171
Reputation: 2,446

Post » Tue Jul 07, 2015 6:09 pm

It's one of the plugins where the source wasn't provided. There likely are some functions in the runtime that enable that plugin to work though.
B
92
S
32
G
109
Posts: 5,290
Reputation: 70,991


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests