Google analytics is only working on emulator [crosswalk]

Discussion and feedback on Construct 2

Post » Tue Sep 09, 2014 11:00 pm

Hello everyone,

I have attempted to use Google analytics I used this plugin:

http://suntemple.co/construct-2/google- ... cs-plugin/

And it works if I am using the intel XDK emulator, I can see all the data and interactions I have with the app. However, if I make the app a crosswalk app, Google Analytics stops working completely.

Has anyone else experienced this before?

Is there any remedy to this issue?

If not, I think I will have to get 100+ monkeys with type writers to figure this one out...
B
16
S
4
Posts: 69
Reputation: 1,834

Post » Wed Sep 10, 2014 3:09 pm

I'm having the same issue - works in preview but not after export.
B
25
S
6
G
3
Posts: 197
Reputation: 3,355

Post » Thu Sep 11, 2014 10:30 am

It is quite frustrating! I spent several hours on trying to get it working yesterday, but it is still not working at all. I was able to find the bug, and it seems a few other people have the same problem.

This is what I found:

Failed to load resource: net::ERR_FILE_NOT_FOUND file://www.google-analytics.com/analytics.js

I tried troubleshooting but I gave up. I really want Google analytics to work, but I can't spend days trying to get to work, when I have to work on the apps I have. I have heard that there are no problems with phonegap, so when iOS8 comes out hopefully it will work on phonegap...
B
16
S
4
Posts: 69
Reputation: 1,834

Post » Fri Sep 19, 2014 2:17 pm

Any solution for this yet?

@cranberrygame I think you are definitely the best man for the job with this. Can you take a look at this link please and see if there is anything you can put together into a plugin to get this working? Thanks :D
ImageImage
Mr. Green - Platform/puzzle game out now!
B
25
S
7
G
1
Posts: 222
Reputation: 3,350


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 11 guests