Google Game Player Login/Logout Stops All Music and Sounds

Get help using Construct 2

Post » Mon Jan 16, 2017 4:00 pm

@Ashley or any experienced user

I'm still learning C2 so i'm not sure of certain things that may happen after a particular event/action. I've been trying to figure out this one problem in my game for days.

I have game music that plays on the start of the main menu layout. If the player leaves that layout, the game music is paused. If they return, the game music is resumed.

Also, on the gameplay layout i have a countdown 3...2...1... (beep sound on each number) and the game and game music starts after the '1' is destroyed, there are also sound fx when stars are destroyed by the ball.

The Problem

Right now, I force login the player before the main menu layout, all music and sounds work. If they logout of google game, all music and sounds stop.

If i move the login to the leaderboard layout, when the player touches the 'Global' button they are logged in to google game, and all music and sounds stop.

If you quit the game (browser closed) and return, all music and sounds play fine, whether the player is logged in or not. I've tried different events/actions on the music and sounds, like 'resume', 'unmuted', 'set not silent'. Nothing seems to work.

Does logging in to google game do anything to the game/browser? Like suspend, loose focus or something else i'm not experienced enough to know?
B
38
S
18
G
19
Posts: 664
Reputation: 14,112

Post » Tue Jan 17, 2017 1:20 pm

Google Play Game Services should function entirely independently of the rest of the game. It sounds like it could just be a mistake in your events. Unless you share a .capx it's pretty much impossible to comment further.
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361

Post » Tue Jan 17, 2017 1:45 pm

Ashley wrote:Google Play Game Services should function entirely independently of the rest of the game. It sounds like it could just be a mistake in your events. Unless you share a .capx it's pretty much impossible to comment further.


Thank you so much for the reply Ashley. I'll go back through all the login/audio events and try to see what's what.

If i still can't find it, i'll do as you say and share the capx.





Thanks again.
B
38
S
18
G
19
Posts: 664
Reputation: 14,112

Post » Thu Jan 19, 2017 2:24 am

@Ashley

I now know its not the log in causing the issue but the leaderboard when its displaying.

If its on 'social' music still works, but if i go to 'all' thats when music stops.

I want to inspect things a bit more to see of i can figure it out. If not, i'll have to post a capx. Seeing this is my only issue thats causing me to promote to beta testing, i may need all the help i can get.
B
38
S
18
G
19
Posts: 664
Reputation: 14,112


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 41 guests