Google Play alert about OpenSSL

Get help using Construct 2

Post » Fri Dec 19, 2014 3:33 pm

Just a heads up from the Intel XDK forums that the next update will come around the first of the year they are saying. Just letting you guys know so we all update as soon as possible when it comes out.
B
21
S
5
G
1
Posts: 102
Reputation: 1,741

Post » Sat Dec 20, 2014 12:17 am

Hello (excuse my english),

please what is the procedure exactly given by @BinaryPanda ?

1) go to http://slproweb.com/products/Win32OpenSSL.html and download what file ?

2) export crosswalk from construct 2 ?

3) Rebuild on intel crosswalk ?

4) publish apk google play ?

Thank you
B
12
S
3
Posts: 147
Reputation: 2,026

Post » Sat Dec 20, 2014 2:00 am

Yes, just as you said. One thing...I had to downloaded "Win64 OpenSSL v1.0.1j". Check to make sure if you have 32bit or 64bit system and download appropriate file. After I published new apk the alert went away for me in under an hour, though it could take as much as 5 for some so be patient.
B
21
S
5
G
1
Posts: 102
Reputation: 1,741

Post » Sat Dec 20, 2014 8:49 am

@chrislechat

Worked for me, too. I went to the link you mentioned and downloaded Win64 OpenSSL v1.0.1j.exe (not the light version - this didn't work for me!). Then I opened Intel XDK and changed nothing except App version and Version code in Android Crosswalk/Build Settings (or else Google won't let you upload the app). I didn't even repeat the export for Crosswalk from C2 (step 2) - I just went over to the step 3, and after that I signed and aligned apk as usual. Then I uploaded the apk to Google Play again. Alert was gone after few hours, and I hope it will stay that way.
B
5
S
2
G
1
Posts: 16
Reputation: 532

Post » Sat Dec 20, 2014 8:51 pm

(excuse my english)
I tried but the alert was not removed after 10 hours.

- I installed the Win32 OpenSSL v1.0.1j file
- I changed the version AppCode
- I build the apk and signed and zipalign.
- I uploaded the apks on Gp

But the alert is still there.

I do not understand why it did not work for me.

but I do not understand why installing openssl locally changes the apk.
the project is uploaded on Intel server and then build on their server and after you download them.
yes or no ?

I will try again and I am going to install
- Visual C ++ 2008 Redistributables
- And reinstall Win32 OpenSSL v1.0.1j

and rebuild the apk 2 and sign and zipalign.
I'm hoping that it works.
B
12
S
3
Posts: 147
Reputation: 2,026

Post » Sat Dec 20, 2014 9:41 pm

chrislechat wrote:(excuse my english)
I tried but the alert was not removed after 10 hours.

- I installed the Win32 OpenSSL v1.0.1j file
- I changed the version AppCode
- I build the apk and signed and zipalign.
- I uploaded the apks on Gp
.......
- And reinstall Win32 OpenSSL v1.0.1j

and rebuild the apk 2 and sign and zipalign.
I'm hoping that it works.

A few questions: Are you on a 32bit or 64bit computer?
Do you manually sign and zipalign your apk?
B
5
S
1
Posts: 8
Reputation: 444

Post » Sat Dec 20, 2014 9:44 pm

- windows 7 32bits
-i sign and zipalign manually apk

why ?
B
12
S
3
Posts: 147
Reputation: 2,026

Post » Sat Dec 20, 2014 10:32 pm

Check if you have Intel XDK version 1621 released on December 18th.
B
21
S
5
G
1
Posts: 102
Reputation: 1,741

Post » Sat Dec 20, 2014 10:35 pm

Also, don't forget that Intel XDK signs your app for you if you want, just lick "Signed" under the appropriate tab in "Build Settings".
B
21
S
5
G
1
Posts: 102
Reputation: 1,741

Post » Sun Dec 21, 2014 1:08 pm

it works !!!


I installed Visual C ++ 2008 Redistributables
- And reinstall Win32 OpenSSL v1.0.1j

-and rebuild the 2 apk and sign and zipalign.
-I disabled the apk with coccon.

it works !!! the warning disappeared.

thank you everybody for your help ! :D
B
12
S
3
Posts: 147
Reputation: 2,026

PreviousNext

Return to How do I....?

Who is online

Users browsing this forum: Armench, Jackriduk, kiki4construct, Laurent and 30 guests